summarylogtreecommitdiffstats
path: root/0004-Makefile-2.13.1.conf.d.patch
diff options
context:
space:
mode:
Diffstat (limited to '0004-Makefile-2.13.1.conf.d.patch')
-rw-r--r--0004-Makefile-2.13.1.conf.d.patch134
1 files changed, 134 insertions, 0 deletions
diff --git a/0004-Makefile-2.13.1.conf.d.patch b/0004-Makefile-2.13.1.conf.d.patch
new file mode 100644
index 000000000000..892d2fc5fe89
--- /dev/null
+++ b/0004-Makefile-2.13.1.conf.d.patch
@@ -0,0 +1,134 @@
+From f7e2933b792c7f7d55fac0c99a4426437f07854f Mon Sep 17 00:00:00 2001
+From: Solomon Choina <shlomochoina@gmail.com>
+Date: Sun, 25 Mar 2018 16:26:59 -0400
+Subject: [PATCH] Makefile-20180325.conf.d
+
+---
+ conf.d/Makefile.am | 42 ++----------------------------------------
+ conf.d/Makefile.in | 28 +++-------------------------
+ 2 files changed, 5 insertions(+), 65 deletions(-)
+
+diff --git a/conf.d/Makefile.am b/conf.d/Makefile.am
+index ff03fb2..a892b04 100644
+--- a/conf.d/Makefile.am
++++ b/conf.d/Makefile.am
+@@ -21,28 +21,10 @@
+ # TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+ # PERFORMANCE OF THIS SOFTWARE.
+
+-BUILT_SOURCES = README
+-DOC_SOURCES = README.in
++
+ DOC_FILES = $(DOC_SOURCES:.in=)
+
+-CONF_LINKS = \
+- 10-hinting-$(PREFERRED_HINTING).conf \
+- 10-scale-bitmap-fonts.conf \
+- 20-unhint-small-vera.conf \
+- 30-metric-aliases.conf \
+- 40-nonlatin.conf \
+- 45-generic.conf \
+- 45-latin.conf \
+- 49-sansserif.conf \
+- 50-user.conf \
+- 51-local.conf \
+- 60-generic.conf \
+- 60-latin.conf \
+- 65-fonts-persian.conf \
+- 65-nonlatin.conf \
+- 69-unifont.conf \
+- 80-delicious.conf \
+- 90-synthetic.conf
++CONF_LINKS =
+
+ EXTRA_DIST = $(template_DATA) $(DOC_SOURCES)
+ CLEANFILES = $(DOC_FILES)
+@@ -87,24 +69,4 @@ template_DATA = \
+ 80-delicious.conf \
+ 90-synthetic.conf
+
+-README: $(srcdir)/README.in
+- sed "s|\@TEMPLATEDIR\@|$(templatedir)|" $< > $@
+-
+-install-data-hook:
+- mkdir -p $(DESTDIR)$(configdir)
+- @(echo cd $(DESTDIR)$(configdir); \
+- cd $(DESTDIR)$(configdir); \
+- for i in $(CONF_LINKS); do \
+- echo $(RM) $$i";" ln -s $(templatedir)/$$i .; \
+- $(RM) $$i; \
+- ln -s $(templatedir)/$$i .; \
+- done)
+-uninstall-local:
+- @(echo cd $(DESTDIR)$(configdir); \
+- cd $(DESTDIR)$(configdir); \
+- for i in $(CONF_LINKS); do \
+- echo $(RM) $$i; \
+- $(RM) $$i; \
+- done)
+-
+ -include $(top_srcdir)/git.mk
+diff --git a/conf.d/Makefile.in b/conf.d/Makefile.in
+index 2c33f6f..7f6ddeb 100644
+--- a/conf.d/Makefile.in
++++ b/conf.d/Makefile.in
+@@ -180,7 +180,7 @@ am__uninstall_files_from_dir = { \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
+-am__installdirs = "$(DESTDIR)$(configdir)" "$(DESTDIR)$(templatedir)"
++am__installdirs = "$(DESTDIR)$(templatedir)"
+ DATA = $(config_DATA) $(template_DATA)
+ am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
+ am__DIST_COMMON = $(srcdir)/Makefile.in README
+@@ -367,27 +367,8 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-BUILT_SOURCES = README
+-DOC_SOURCES = README.in
+ DOC_FILES = $(DOC_SOURCES:.in=)
+-CONF_LINKS = \
+- 10-hinting-$(PREFERRED_HINTING).conf \
+- 10-scale-bitmap-fonts.conf \
+- 20-unhint-small-vera.conf \
+- 30-metric-aliases.conf \
+- 40-nonlatin.conf \
+- 45-generic.conf \
+- 45-latin.conf \
+- 49-sansserif.conf \
+- 50-user.conf \
+- 51-local.conf \
+- 60-generic.conf \
+- 60-latin.conf \
+- 65-fonts-persian.conf \
+- 65-nonlatin.conf \
+- 69-unifont.conf \
+- 80-delicious.conf \
+- 90-synthetic.conf
++CONF_LINKS =
+
+ EXTRA_DIST = $(template_DATA) $(DOC_SOURCES)
+ CLEANFILES = $(DOC_FILES)
+@@ -553,7 +534,7 @@ check: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) check-am
+ all-am: Makefile $(DATA)
+ installdirs:
+- for dir in "$(DESTDIR)$(configdir)" "$(DESTDIR)$(templatedir)"; do \
++ for dir in "$(DESTDIR)$(templatedir)"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: $(BUILT_SOURCES)
+@@ -676,9 +657,6 @@ uninstall-am: uninstall-configDATA uninstall-local \
+ .PRECIOUS: Makefile
+
+
+-README: $(srcdir)/README.in
+- sed "s|\@TEMPLATEDIR\@|$(templatedir)|" $< > $@
+-
+ install-data-hook:
+ mkdir -p $(DESTDIR)$(configdir)
+ @(echo cd $(DESTDIR)$(configdir); \
+--
+2.16.3
+