summarylogtreecommitdiffstats
path: root/0005-MINGW-configure-MACHDEP-and-platform-for-build.patch
diff options
context:
space:
mode:
Diffstat (limited to '0005-MINGW-configure-MACHDEP-and-platform-for-build.patch')
-rw-r--r--0005-MINGW-configure-MACHDEP-and-platform-for-build.patch66
1 files changed, 24 insertions, 42 deletions
diff --git a/0005-MINGW-configure-MACHDEP-and-platform-for-build.patch b/0005-MINGW-configure-MACHDEP-and-platform-for-build.patch
index 1d90fd3be106..bfc88a442506 100644
--- a/0005-MINGW-configure-MACHDEP-and-platform-for-build.patch
+++ b/0005-MINGW-configure-MACHDEP-and-platform-for-build.patch
@@ -1,4 +1,4 @@
-From fa68425708485de2cea225d6c3ff58bff6965ab5 Mon Sep 17 00:00:00 2001
+From c2c04f16d3f6761a9ee768507c0ca8330c976ce6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=D0=90=D0=BB=D0=B5=D0=BA=D1=81=D0=B5=D0=B9?=
<alexey.pawlow@gmail.com>
Date: Thu, 17 Jun 2021 18:51:14 +0530
@@ -9,50 +9,32 @@ Content-Transfer-Encoding: 8bit
Co-authored-by: Алексей <alexey.pawlow@gmail.com>
---
- Python/getplatform.c | 6 ++++++
- configure.ac | 22 ++++++++++++++++++++++
- 2 files changed, 28 insertions(+)
+ configure.ac | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
-diff --git a/Python/getplatform.c b/Python/getplatform.c
-index 81a0f7a..636b0a8 100644
---- a/Python/getplatform.c
-+++ b/Python/getplatform.c
-@@ -1,6 +1,12 @@
-
- #include "Python.h"
-
-+#ifdef __MINGW32__
-+# undef PLATFORM
-+/* see PC/pyconfig.h */
-+# define PLATFORM "win32"
-+#endif
-+
- #ifndef PLATFORM
- #define PLATFORM "unknown"
- #endif
diff --git a/configure.ac b/configure.ac
-index 005fc8f..ecdf22d 100644
+index d5766cf..a9936de 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -383,6 +383,17 @@ AC_DEFINE_UNQUOTED(_PYTHONFRAMEWORK, "${PYTHONFRAMEWORK}", [framework name])
- # Set name for machine-dependent library files
- AC_ARG_VAR([MACHDEP], [name for machine-dependent library files])
- AC_MSG_CHECKING(MACHDEP)
-+case $host in
-+ *-*-mingw*)
-+ # On those hosts MACHDEP is 'win', as platform specific files
-+ # go in plat-$(MACHDEP), but runtime platform is 'win32'
-+ test -z "$MACHDEP" && MACHDEP=win
-+
-+ dnl Configuration will be based only on "host triplet" as build
-+ dnl must not depend from posix compatible environement.
-+ ac_sys_system=ignore
-+ ;;
-+esac
- if test -z "$MACHDEP"
- then
- # avoid using uname for cross builds
-@@ -452,12 +463,23 @@ if test "$cross_compiling" = yes; then
+@@ -400,6 +400,9 @@ then
+ *-*-cygwin*)
+ ac_sys_system=Cygwin
+ ;;
++ *-*-mingw*)
++ ac_sys_system=MINGW
++ ;;
+ *-*-vxworks*)
+ ac_sys_system=VxWorks
+ ;;
+@@ -429,6 +432,7 @@ then
+ linux*) MACHDEP="linux";;
+ cygwin*) MACHDEP="cygwin";;
+ darwin*) MACHDEP="darwin";;
++ mingw*) MACHDEP="win32";;
+ '') MACHDEP="unknown";;
+ esac
+ fi
+@@ -452,12 +456,23 @@ if test "$cross_compiling" = yes; then
*-*-vxworks*)
_host_cpu=$host_cpu
;;
@@ -77,5 +59,5 @@ index 005fc8f..ecdf22d 100644
# Some systems cannot stand _XOPEN_SOURCE being defined at all; they
--
-2.32.0
+2.33.0