summarylogtreecommitdiffstats
path: root/0007-AUR-Enable-winewayland.patch
diff options
context:
space:
mode:
Diffstat (limited to '0007-AUR-Enable-winewayland.patch')
-rw-r--r--0007-AUR-Enable-winewayland.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/0007-AUR-Enable-winewayland.patch b/0007-AUR-Enable-winewayland.patch
new file mode 100644
index 000000000000..55ff72efd798
--- /dev/null
+++ b/0007-AUR-Enable-winewayland.patch
@@ -0,0 +1,44 @@
+From 58045d3c4da226d6df5be7f0ba80bebeef7a0134 Mon Sep 17 00:00:00 2001
+From: Stelios Tsampas <loathingkernel@gmail.com>
+Date: Thu, 29 Feb 2024 15:28:48 +0200
+Subject: [PATCH 7/7] AUR Enable winewayland
+
+---
+ Makefile.in | 1 +
+ proton | 8 ++++++++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/Makefile.in b/Makefile.in
+index 99ee6e17..581b981c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -426,6 +426,7 @@ WINE_SOURCE_ARGS = \
+
+ WINE_CONFIGURE_ARGS = \
+ --with-x \
++ --with-wayland \
+ --with-gstreamer \
+ --with-mingw \
+ --without-oss \
+diff --git a/proton b/proton
+index 89baeb8e..ca22cda3 100755
+--- a/proton
++++ b/proton
+@@ -1524,6 +1524,14 @@ if __name__ == "__main__":
+ elif sys.argv[1] == "waitforexitandrun":
+ #wait for wineserver to shut down
+ g_session.run_proc([g_proton.wineserver_bin, "-w"])
++ winedrv = "x11"
++ if os.environ.get("PROTON_ENABLE_WAYLAND", False):
++ del os.environ["DISPLAY"]
++ winedrv = "wayland"
++ g_session.run_proc(
++ [g_proton.wine_bin, "reg.exe", "add", "HKCU\\Software\\Wine\\Drivers", "/v", "Graphics", "/d", f"{winedrv}", "/f"]
++ )
++ g_session.run_proc([g_proton.wineserver_bin, "-w"])
+ #then run
+ rc = g_session.run()
+ elif sys.argv[1] == "runinprefix":
+--
+2.44.0
+