summarylogtreecommitdiffstats
path: root/0008-USB-armory-support.patch
diff options
context:
space:
mode:
Diffstat (limited to '0008-USB-armory-support.patch')
-rw-r--r--0008-USB-armory-support.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/0008-USB-armory-support.patch b/0008-USB-armory-support.patch
index 14e8e2530d55..5b4309080a41 100644
--- a/0008-USB-armory-support.patch
+++ b/0008-USB-armory-support.patch
@@ -1,7 +1,7 @@
-From 0bef4c3483f1a30f027ae375e1c04a2e6be91150 Mon Sep 17 00:00:00 2001
+From 19ca41a82a2fde0e6cd80b70ab1deb2b793edb86 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 7 Feb 2015 12:32:27 +0100
-Subject: [PATCH 8/9] USB armory support
+Subject: [PATCH 8/8] USB armory support
---
arch/arm/boot/dts/Makefile | 5 +
@@ -20,10 +20,10 @@ Subject: [PATCH 8/9] USB armory support
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 4a41a60..a2df2c2 100644
+index c710c30..e9a95ef 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -268,6 +268,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
+@@ -287,6 +287,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
imx53-smd.dtb \
imx53-tx53-x03x.dtb \
imx53-tx53-x13x.dtb \
@@ -37,7 +37,7 @@ index 4a41a60..a2df2c2 100644
imx6dl-apf6dev.dtb \
diff --git a/arch/arm/boot/dts/imx53-usbarmory-common.dtsi b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
new file mode 100644
-index 0000000..b73c399
+index 0000000..6f9ca1d
--- /dev/null
+++ b/arch/arm/boot/dts/imx53-usbarmory-common.dtsi
@@ -0,0 +1,241 @@
@@ -74,7 +74,7 @@ index 0000000..b73c399
+
+ user {
+ label = "LED";
-+ gpios = <&gpio4 27 0>;
++ gpios = <&gpio4 27 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "heartbeat";
+ };
+ };
@@ -452,5 +452,5 @@ index 0000000..902a73b
+ status = "okay";
+};
--
-2.6.4
+2.7.0