summarylogtreecommitdiffstats
path: root/0008-ZEN-Disable-stack-conservation-for-GCC.patch
diff options
context:
space:
mode:
Diffstat (limited to '0008-ZEN-Disable-stack-conservation-for-GCC.patch')
-rw-r--r--0008-ZEN-Disable-stack-conservation-for-GCC.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/0008-ZEN-Disable-stack-conservation-for-GCC.patch b/0008-ZEN-Disable-stack-conservation-for-GCC.patch
deleted file mode 100644
index c9365acc6954..000000000000
--- a/0008-ZEN-Disable-stack-conservation-for-GCC.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Sultan Alsawaf <sultan@kerneltoast.com>
-Date: Sun, 8 Mar 2020 00:31:35 -0800
-Subject: [PATCH] ZEN: Disable stack conservation for GCC
-
-There's plenty of room on the stack for a few more inlined bytes here
-and there. The measured stack usage at runtime is still safe without
-this, and performance is surely improved at a microscopic level, so
-remove it.
-
-Signed-off-by: Sultan Alsawaf <sultan@kerneltoast.com>
----
- Makefile | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 158e3bda7d35644e1fe978d66e72382c665d1079..09576ba3a533234686e803a0c1665b82ad4b745a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -992,11 +992,6 @@ KBUILD_CFLAGS += -fno-strict-overflow
- # Make sure -fstack-check isn't enabled (like gentoo apparently did)
- KBUILD_CFLAGS += -fno-stack-check
-
--# conserve stack if available
--ifdef CONFIG_CC_IS_GCC
--KBUILD_CFLAGS += -fconserve-stack
--endif
--
- # Prohibit date/time macros, which would make the build non-deterministic
- KBUILD_CFLAGS += -Werror=date-time
-