summarylogtreecommitdiffstats
path: root/0009-ZEN-Initialize-ata-before-graphics.patch
diff options
context:
space:
mode:
Diffstat (limited to '0009-ZEN-Initialize-ata-before-graphics.patch')
-rw-r--r--0009-ZEN-Initialize-ata-before-graphics.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/0009-ZEN-Initialize-ata-before-graphics.patch b/0009-ZEN-Initialize-ata-before-graphics.patch
deleted file mode 100644
index 7bb50cfc667d..000000000000
--- a/0009-ZEN-Initialize-ata-before-graphics.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Arjan van de Ven <arjan@linux.intel.com>
-Date: Thu, 2 Jun 2016 23:36:32 -0500
-Subject: [PATCH] ZEN: Initialize ata before graphics
-
-ATA init is the long pole in the boot process, and its asynchronous.
-move the graphics init after it so that ata and graphics initialize
-in parallel
----
- drivers/Makefile | 15 ++++++++-------
- 1 file changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/drivers/Makefile b/drivers/Makefile
-index 9a30842b22c5411bf00245761f472da9c13370b7..32afd317d95ecab6f1fe9a42d3977b6c0a917023 100644
---- a/drivers/Makefile
-+++ b/drivers/Makefile
-@@ -59,15 +59,8 @@ obj-y += char/
- # iommu/ comes before gpu as gpu are using iommu controllers
- obj-y += iommu/
-
--# gpu/ comes after char for AGP vs DRM startup and after iommu
--obj-y += gpu/
--
- obj-$(CONFIG_CONNECTOR) += connector/
-
--# i810fb and intelfb depend on char/agp/
--obj-$(CONFIG_FB_I810) += video/fbdev/i810/
--obj-$(CONFIG_FB_INTEL) += video/fbdev/intelfb/
--
- obj-$(CONFIG_PARPORT) += parport/
- obj-y += base/ block/ misc/ mfd/ nfc/
- obj-$(CONFIG_LIBNVDIMM) += nvdimm/
-@@ -79,6 +72,14 @@ obj-y += macintosh/
- obj-y += scsi/
- obj-y += nvme/
- obj-$(CONFIG_ATA) += ata/
-+
-+# gpu/ comes after char for AGP vs DRM startup and after iommu
-+obj-y += gpu/
-+
-+# i810fb and intelfb depend on char/agp/
-+obj-$(CONFIG_FB_I810) += video/fbdev/i810/
-+obj-$(CONFIG_FB_INTEL) += video/fbdev/intelfb/
-+
- obj-$(CONFIG_TARGET_CORE) += target/
- obj-$(CONFIG_MTD) += mtd/
- obj-$(CONFIG_SPI) += spi/