summarylogtreecommitdiffstats
path: root/001-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to '001-makefile.patch')
-rw-r--r--001-makefile.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/001-makefile.patch b/001-makefile.patch
new file mode 100644
index 000000000000..20fb6018c4a9
--- /dev/null
+++ b/001-makefile.patch
@@ -0,0 +1,36 @@
+Description: Use variables in makefile
+ Allow Debian defaults to be used for CXX etc.
+ xbrz v18 needs C++17
+
+Author: P Blackman <peter@pblackman.plus.com>
+Last-Update: 2020-08-31
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -1,21 +1,19 @@
+ all: xbrzscale
+
+ xbrz/xbrz.o: xbrz/xbrz.cpp xbrz/xbrz.h
+- g++ -std=c++11 -c -o xbrz/xbrz.o xbrz/xbrz.cpp -DNDEBUG
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o xbrz/xbrz.o xbrz/xbrz.cpp -DNDEBUG
+
+ libxbrzscale.o: libxbrzscale.cpp xbrz/xbrz.h
+- g++ -std=c++11 -c -o libxbrzscale.o libxbrzscale.cpp `sdl2-config --cflags`
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o libxbrzscale.o libxbrzscale.cpp `sdl2-config --cflags`
+
+ xbrzscale.o: xbrzscale.cpp libxbrzscale.h xbrz/xbrz.h
+- g++ -std=c++11 -c -o xbrzscale.o xbrzscale.cpp `sdl2-config --cflags`
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o xbrzscale.o xbrzscale.cpp `sdl2-config --cflags`
+
+ libxbrzscale.a: libxbrzscale.o xbrz/xbrz.o
+ ar qc libxbrzscale.a libxbrzscale.o xbrz/xbrz.o
+
+ xbrzscale: xbrzscale.o libxbrzscale.a
+- g++ -o xbrzscale xbrzscale.o libxbrzscale.a -lSDL2_image `sdl2-config --libs`
+-#xbrzscale: xbrzscale.o libxbrzscale.o xbrz/xbrz.o
+-# g++ -o xbrzscale xbrzscale.o libxbrzscale.o xbrz/xbrz.o -lSDL2_image `sdl2-config --libs`
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o xbrzscale xbrzscale.o libxbrzscale.a -lSDL2_image `sdl2-config --libs`
+
+ clean:
+ rm -vf xbrzscale.o xbrz/xbrz.o libxbrzscale.o libxbrzscale.a xbrzscale