summarylogtreecommitdiffstats
path: root/001-setup.py.patch
diff options
context:
space:
mode:
Diffstat (limited to '001-setup.py.patch')
-rw-r--r--001-setup.py.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/001-setup.py.patch b/001-setup.py.patch
new file mode 100644
index 000000000000..2108419dbf92
--- /dev/null
+++ b/001-setup.py.patch
@@ -0,0 +1,73 @@
+diff --git a/setup.py b/setup.py
+index 4e8e78a..2a49b6c 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1,41 +1,34 @@
+ #!/usr/bin/env python
+
+-import sys
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
+-
+-if sys.version_info < (2,5):
+- raise NotImplementedError("Sorry, you need at least Python 2.5 or Python 3.x")
++from setuptools import setup
+
+ import contexter
+
+-with contexter.Contexter() as ctx:
+- long_description = ''.join(ctx << open('README.rst'))
+-
+-setup(name='contexter',
+- version=contexter.__version__,
+- description=contexter.__doc__,
+- long_description=long_description,
+- author=contexter.__author__,
+- author_email='marc@gsites.de',
+- url='https://bitbucket.org/defnull/contexter',
+- py_modules=['contexter'],
+- license='MIT',
+- platforms = 'any',
+- classifiers=['Development Status :: 4 - Beta',
+- 'Intended Audience :: Developers',
+- 'License :: OSI Approved :: MIT License',
+- 'Programming Language :: Python :: 2.5',
+- 'Programming Language :: Python :: 2.6',
+- 'Programming Language :: Python :: 2.7',
+- 'Programming Language :: Python :: 3',
+- 'Programming Language :: Python :: 3.2',
+- 'Programming Language :: Python :: 3.3',
+- 'Programming Language :: Python :: 3.4',
+- ],
++with open('README.rst') as f:
++ long_description = f.read()
++
++setup(
++ name='contexter',
++ version=contexter.__version__,
++ description='Full replacement of the contextlib standard library module',
++ long_description=long_description,
++ author=contexter.__author__,
++ author_email='marc@gsites.de',
++ url='https://bitbucket.org/defnull/contexter',
++ py_modules=['contexter'],
++ license='MIT',
++ platforms = 'any',
++ python_requres='>=2.5',
++ classifiers=['Development Status :: 4 - Beta',
++ 'Intended Audience :: Developers',
++ 'License :: OSI Approved :: MIT License',
++ 'Programming Language :: Python :: 2.5',
++ 'Programming Language :: Python :: 2.6',
++ 'Programming Language :: Python :: 2.7',
++ 'Programming Language :: Python :: 3',
++ 'Programming Language :: Python :: 3.2',
++ 'Programming Language :: Python :: 3.3',
++ 'Programming Language :: Python :: 3.4',
++ ],
+ )
+
+-
+-