summarylogtreecommitdiffstats
path: root/001-setup.py.patch
diff options
context:
space:
mode:
Diffstat (limited to '001-setup.py.patch')
-rw-r--r--001-setup.py.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/001-setup.py.patch b/001-setup.py.patch
new file mode 100644
index 000000000000..60b6df2d2348
--- /dev/null
+++ b/001-setup.py.patch
@@ -0,0 +1,58 @@
+diff --git a/setup.py b/../setup.py
+index f026096..c75e598 100755
+--- a/setup.py
++++ b/../setup.py
+@@ -6,20 +6,23 @@ import os
+
+
+ def create_default_dir():
+- default_dir = os.path.normpath(os.path.realpath((os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
++ default_dir = os.path.normpath(os.path.realpath(
++ (os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
+ if not os.path.exists(default_dir):
+ print("Creating default settings directory: " + default_dir)
+ os.makedirs(default_dir.encode("utf-8"))
+
++
+ def _read(fn):
+ path = os.path.join(os.path.dirname(__file__), fn)
+ return open(path).read()
+
++
+ setup(
+ name='spotify-ripper',
+ version='2.18',
+ packages=find_packages(exclude=["tests"]),
+- #scripts=['spotify_ripper/main.py'],
++ # scripts=['spotify_ripper/main.py'],
+ include_package_data=True,
+ zip_safe=False,
+
+@@ -37,12 +40,12 @@ setup(
+
+ # Requirements
+ install_requires=[
+- 'pyspotify>=2.0.5',
+- 'colorama>=0.3.3',
+- 'mutagen>=1.30',
+- 'requests>=2.13.0',
+- 'schedule>=0.3.1',
+- 'spotipy>=2.4.4'
++ 'pyspotify',
++ 'colorama',
++ 'mutagen',
++ 'requests',
++ 'schedule',
++ 'spotipy'
+ ],
+
+ # Metadata
+@@ -52,7 +55,7 @@ setup(
+ license='MIT',
+ keywords="spotify ripper mp3 ogg vorbis flac opus acc mp4 m4a",
+ url='https://github.com/scaronni/spotify-ripper',
+- download_url='https://github.com/scaronni/spotify-ripper/tarball/2.15',
++ download_url='https://github.com/scaronni/spotify-ripper/tarball/2.18',
+ classifiers=[
+ 'Topic :: Multimedia :: Sound/Audio',
+ 'Topic :: Multimedia :: Sound/Audio :: Capture/Recording',