summarylogtreecommitdiffstats
path: root/0011-libobs-Add-a-Wayland-platform.patch
diff options
context:
space:
mode:
Diffstat (limited to '0011-libobs-Add-a-Wayland-platform.patch')
-rw-r--r--0011-libobs-Add-a-Wayland-platform.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/0011-libobs-Add-a-Wayland-platform.patch b/0011-libobs-Add-a-Wayland-platform.patch
index baeba83ed5cf..3a9d60da20bb 100644
--- a/0011-libobs-Add-a-Wayland-platform.patch
+++ b/0011-libobs-Add-a-Wayland-platform.patch
@@ -1,7 +1,7 @@
-From 20b8264570f84ddc218b791643d26e168653ffbe Mon Sep 17 00:00:00 2001
+From eb2b38d24454b1fdd21cb8184a224cb9fa0579d3 Mon Sep 17 00:00:00 2001
From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
Date: Fri, 6 Mar 2020 18:53:42 -0300
-Subject: [PATCH 11/24] libobs: Add a Wayland platform
+Subject: [PATCH 11/25] libobs: Add a Wayland platform
Introduce the OBS_NIX_PLATFORM_WAYLAND enum value, and try to detect
it when OBS Studio runs by looking into the platform name.
@@ -24,10 +24,10 @@ it when OBS Studio runs by looking into the platform name.
create mode 100644 libobs/obs-nix-wayland.h
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b56c2bba..9ab530ce 100644
+index 5bdfe21f..7828c65a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -189,6 +189,8 @@ if(APPLE)
+@@ -205,6 +205,8 @@ if(APPLE)
list(APPEND CMAKE_INSTALL_RPATH "@loader_path/" "@executable_path/")
elseif(UNIX)
option(USE_XDG "Utilize XDG Base Directory Specification" ON)
@@ -37,12 +37,12 @@ index b56c2bba..9ab530ce 100644
add_definitions(-DUSE_XDG)
endif()
diff --git a/UI/CMakeLists.txt b/UI/CMakeLists.txt
-index a660f326..56195d7d 100644
+index df4d2645..ae689c95 100644
--- a/UI/CMakeLists.txt
+++ b/UI/CMakeLists.txt
-@@ -403,6 +403,11 @@ if (APPLE)
- set_target_properties(obs PROPERTIES LINK_FLAGS "-pagezero_size 10000 -image_base 100000000")
+@@ -408,6 +408,11 @@ if (APPLE)
endif()
+ set_target_properties(obs PROPERTIES FOLDER "frontend")
+if (ENABLE_WAYLAND)
+ find_package(Qt5Gui REQUIRED)
@@ -53,10 +53,10 @@ index a660f326..56195d7d 100644
install_obs_core(obs)
diff --git a/UI/obs-app.cpp b/UI/obs-app.cpp
-index c62ba1da..8335c2ce 100644
+index 2a8de8d9..ce350f06 100644
--- a/UI/obs-app.cpp
+++ b/UI/obs-app.cpp
-@@ -57,6 +57,11 @@
+@@ -59,6 +59,11 @@
#if !defined(_WIN32) && !defined(__APPLE__)
#include <obs-nix-platform.h>
#include <QX11Info>
@@ -68,7 +68,7 @@ index c62ba1da..8335c2ce 100644
#endif
#include <iostream>
-@@ -1360,6 +1365,18 @@ bool OBSApp::OBSInit()
+@@ -1383,6 +1388,18 @@ bool OBSApp::OBSInit()
}
obs_set_nix_platform_display(QX11Info::display());
}
@@ -172,7 +172,7 @@ index 00000000..377f0545
+
+ENDIF ()
diff --git a/libobs-opengl/CMakeLists.txt b/libobs-opengl/CMakeLists.txt
-index 9c645c3d..f84636cf 100644
+index 973c5da3..08e06f0d 100644
--- a/libobs-opengl/CMakeLists.txt
+++ b/libobs-opengl/CMakeLists.txt
@@ -32,7 +32,7 @@ elseif(APPLE)
@@ -201,10 +201,10 @@ index 9ed3d198..581e16a4 100644
assert(gl_vtable != NULL);
diff --git a/libobs/CMakeLists.txt b/libobs/CMakeLists.txt
-index 489334c0..1cb1583b 100644
+index 7a786350..860ad1c8 100644
--- a/libobs/CMakeLists.txt
+++ b/libobs/CMakeLists.txt
-@@ -189,6 +189,21 @@ elseif(UNIX)
+@@ -190,6 +190,21 @@ elseif(UNIX)
set(libobs_PLATFORM_HEADERS
obs-nix-platform.h)