summarylogtreecommitdiffstats
path: root/002_disable_postinstall.patch
diff options
context:
space:
mode:
Diffstat (limited to '002_disable_postinstall.patch')
-rw-r--r--002_disable_postinstall.patch23
1 files changed, 10 insertions, 13 deletions
diff --git a/002_disable_postinstall.patch b/002_disable_postinstall.patch
index 81e5a3c1601e..53320209af41 100644
--- a/002_disable_postinstall.patch
+++ b/002_disable_postinstall.patch
@@ -1,13 +1,10 @@
---- cmake_install.cmake.orig 2017-04-16 13:13:40.562121665 +0200
-+++ cmake_install.cmake 2017-04-16 13:14:02.932269460 +0200
-@@ -104,10 +104,6 @@
- endif()
- endif()
-
--if("${CMAKE_INSTALL_COMPONENT}" STREQUAL "script" OR NOT CMAKE_INSTALL_COMPONENT)
-- include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/ThunderboltService/Linux/post_install_script.cmake")
--endif()
--
- if(NOT CMAKE_INSTALL_LOCAL_ONLY)
- # Include the install script for each subdirectory.
- include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/build/gmock/cmake_install.cmake")
+--- ThunderboltService/Linux/CMakeLists.txt.orig 2017-04-16 14:04:49.297485952 +0200
++++ ThunderboltService/Linux/CMakeLists.txt 2017-04-16 14:05:02.064226810 +0200
+@@ -163,7 +163,6 @@
+ install(FILES ${CONFIG_DIR}/thunderbolt.conf DESTINATION ${DBUS_CONFIG_DIR} COMPONENT config)
+ install(FILES ${CONFIG_DIR}/10-thunderbolt.rules DESTINATION ${UDEV_RULES_DIR} COMPONENT config)
+ install(TARGETS thunderboltd DESTINATION ${DAEMON_INSTALL_DIR} COMPONENT binary)
+- install(SCRIPT post_install_script.cmake COMPONENT script)
+ else()
+ message(WARNING
+ "Can't install Thunderbolt daemon because systemd or dbus couldn't be found")