summarylogtreecommitdiffstats
path: root/003-graphite2-1.3.8-staticbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to '003-graphite2-1.3.8-staticbuild.patch')
-rw-r--r--003-graphite2-1.3.8-staticbuild.patch6
1 files changed, 2 insertions, 4 deletions
diff --git a/003-graphite2-1.3.8-staticbuild.patch b/003-graphite2-1.3.8-staticbuild.patch
index 74b864e31415..ab37b1ec0009 100644
--- a/003-graphite2-1.3.8-staticbuild.patch
+++ b/003-graphite2-1.3.8-staticbuild.patch
@@ -1,6 +1,6 @@
--- graphite2-1.3.8/src/CMakeLists.txt.orig 2016-09-17 06:30:02.570522500 -0400
+++ graphite2-1.3.8/src/CMakeLists.txt 2016-09-17 06:33:57.962672400 -0400
-@@ -106,6 +106,48 @@
+@@ -106,6 +106,46 @@
LT_VERSION_REVISION ${GRAPHITE_API_REVISION}
LT_VERSION_AGE ${GRAPHITE_API_AGE})
@@ -13,7 +13,6 @@
+ gr_logging.cpp
+ gr_segment.cpp
+ gr_slot.cpp
-+ CachedFace.cpp
+ CmapCache.cpp
+ Code.cpp
+ Collider.cpp
@@ -35,7 +34,6 @@
+ TtfUtil.cpp
+ UtfCodec.cpp
+ ${FILEFACE}
-+ ${SEGCACHE}
+ ${TRACING})
+
+set_target_properties(graphite2_static PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
@@ -49,7 +47,7 @@
if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
set_target_properties(graphite2 PROPERTIES
COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector"
-@@ -148,8 +190,11 @@
+@@ -148,8 +188,11 @@
if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
set_target_properties(graphite2 PROPERTIES
COMPILE_DEFINITIONS "_SCL_SECURE_NO_WARNINGS;_CRT_SECURE_NO_WARNINGS;UNICODE;GRAPHITE2_EXPORTING")