summarylogtreecommitdiffstats
path: root/004-drop-Wno-format.patch
diff options
context:
space:
mode:
Diffstat (limited to '004-drop-Wno-format.patch')
-rw-r--r--004-drop-Wno-format.patch84
1 files changed, 84 insertions, 0 deletions
diff --git a/004-drop-Wno-format.patch b/004-drop-Wno-format.patch
new file mode 100644
index 000000000000..d8f7e22e51f0
--- /dev/null
+++ b/004-drop-Wno-format.patch
@@ -0,0 +1,84 @@
+From 6fed8ce04e50522c690ffa4bb100c1dd00ee4d36 Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Tue, 18 Apr 2023 22:59:50 +0200
+Subject: [PATCH 1/1] drop -Wno-format
+
+---
+ src/VBox/Devices/EFI/Firmware/Config.kmk | 2 +-
+ src/VBox/Devices/Makefile.kmk | 2 +-
+ src/VBox/Devices/PC/ipxe/Makefile.kmk | 2 +-
+ src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk | 2 +-
+ src/VBox/Main/webservice/Makefile.kmk | 3 +--
+ 5 files changed
+
+diff --git a/src/VBox/Devices/EFI/Firmware/Config.kmk b/src/VBox/Devices/EFI/Firmware/Config.kmk
+index ddd1fc1e..0614d90c 100644
+--- a/src/VBox/Devices/EFI/Firmware/Config.kmk
++++ b/src/VBox/Devices/EFI/Firmware/Config.kmk
+@@ -155,7 +155,7 @@ TEMPLATE_VBoxEfiBldProg_LIBS = \
+ ifn1of ($(KBUILD_HOST), win) # This stuff isn't up to our standard at all! :/
+ TEMPLATE_VBoxEfiBldProg_CFLAGS = $(filter-out -pedantic,$(TEMPLATE_VBoxBldProg_CFLAGS)) \
+ -Wno-sign-compare -Wno-missing-prototypes -Wno-strict-prototypes \
+- -Wno-implicit-function-declaration -Wno-missing-declarations -Wno-shadow -Wno-format \
++ -Wno-implicit-function-declaration -Wno-missing-declarations -Wno-shadow \
+ -Wno-empty-body -Wno-unused-parameter -Wno-unused-variable -Wno-unused-label
+ TEMPLATE_VBoxEfiBldProg_CXXFLAGS = $(filter-out -pedantic,$(TEMPLATE_VBoxBldProg_CXXFLAGS)) \
+ -Wno-all -Wno-shadow -Wno-empty-body -Wno-unused-parameter -Wno-unused-variable \
+diff --git a/src/VBox/Devices/Makefile.kmk b/src/VBox/Devices/Makefile.kmk
+index a17e655f..fe905681 100644
+@@ -853,7 +853,7 @@ if !defined(VBOX_ONLY_EXTPACKS) && "$(in
+ ifeq ($(KBUILD_TARGET),win)
+ $(file)_CFLAGS = -wd4018
+ else
+- $(file)_CFLAGS += -Wno-sign-compare -Wno-format -Wno-bad-function-cast
++ $(file)_CFLAGS += -Wno-sign-compare -Wno-bad-function-cast
+ endif
+ endef
+
+diff --git a/src/VBox/Devices/PC/ipxe/Makefile.kmk b/src/VBox/Devices/PC/ipxe/Makefile.kmk
+index 7f5b4c5a..33705fe7 100644
+--- a/src/VBox/Devices/PC/ipxe/Makefile.kmk
++++ b/src/VBox/Devices/PC/ipxe/Makefile.kmk
+@@ -396,7 +396,7 @@ endif
+ #
+ BLDPROGS += ipxezbin
+ ipxezbin_TEMPLATE = VBoxBldProg
+- ipxezbin_CFLAGS = -Wno-format -Wno-unused-function -Wno-pointer-arith
++ ipxezbin_CFLAGS = -Wno-unused-function -Wno-pointer-arith
+ ipxezbin_SOURCES = src/util/zbin.c
+ ifdef VBOX_WITH_LIBLZMA
+ ipxezbin_INCS = $(SDK_VBoxLibLzma_INCS) # Can't use the proper SDK here as link order matters and liblzma depends on our runtime.
+diff --git a/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk b/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
+index 081f02b0..75fe411b 100644
+--- a/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
++++ b/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
+@@ -118,7 +118,7 @@ if defined(VBOX_WITH_EXTPACK_VBOXDTRACE) && defined(VBOX_WITH_EXTPACK)
+ VBoxDTraceCmd_DEFS.win = YY_USE_PROTOS=1 YYENABLE_NLS=0 YYLTYPE_IS_TRIVIAL=0
+ VBoxDTraceCmd_SDKS = VBoxZlib
+ ifn1of ($(KBUILD_TARGET), win)
+- VBoxDTraceCmd_CFLAGS = -Wno-format $(VBOX_GCC_Wno-overlength-strings) -Wno-sign-compare -Wno-strict-prototypes -Wno-missing-prototypes -Wno-missing-declarations -Wno-shadow
++ VBoxDTraceCmd_CFLAGS = $(VBOX_GCC_Wno-overlength-strings) -Wno-sign-compare -Wno-strict-prototypes -Wno-missing-prototypes -Wno-missing-declarations -Wno-shadow
+ endif
+ VBoxDTraceCmd_INCS = \
+ include \
+diff --git a/src/VBox/Main/webservice/Makefile.kmk b/src/VBox/Main/webservice/Makefile.kmk
+index dbccdf4f..c6093ed4 100644
+--- a/src/VBox/Main/webservice/Makefile.kmk
++++ b/src/VBox/Main/webservice/Makefile.kmk
+@@ -264,7 +264,7 @@ ifdef VBOX_GSOAP_INSTALLED
+ ifn1of ($(KBUILD_TARGET), win)
+ vboxsoap_CXXFLAGS += -Wno-shadow -Wno-parentheses $(VBOX_GCC_Wno-literal-suffix) \
+ $(VBOX_GCC_Wno-stringop-overflow) $(VBOX_GCC_Wno-stringop-truncation) \
+- $(VBOX_GCC_Wno-vla) -Wno-format -Wno-deprecated-declarations $(VBOX_GCC_fno-printf-return-value)
++ $(VBOX_GCC_Wno-vla) -Wno-deprecated-declarations $(VBOX_GCC_fno-printf-return-value)
+ ifn1of ($(KBUILD_TYPE), debug) # Save time+memory by using -O0 instead of -O2.
+ vboxsoap_CXXFLAGS += -O0 ## @todo this could be interesting for g++ (not clang++): -fcprop-registers
+ endif
+@@ -335,7 +335,6 @@ ifdef VBOX_GSOAP_INSTALLED
+ $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts
+ ifn1of ($(KBUILD_TARGET), win)
+ $(VBOX_GSOAP_CXX_SOURCES)_CXXFLAGS = \
+- -Wno-format \
+ $(VBOX_GCC_Wno-int-in-bool-context) \
+ $(VBOX_GCC_Wno-logical-op)
+ # currently necessary when compiling against OpenSSL 1.0 due to a missing