summarylogtreecommitdiffstats
path: root/005-ffmpeg-add-svt-hevc-gb62f72e.patch
diff options
context:
space:
mode:
Diffstat (limited to '005-ffmpeg-add-svt-hevc-gb62f72e.patch')
-rw-r--r--005-ffmpeg-add-svt-hevc-gb62f72e.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/005-ffmpeg-add-svt-hevc-gb62f72e.patch b/005-ffmpeg-add-svt-hevc-gb62f72e.patch
new file mode 100644
index 000000000000..382979931105
--- /dev/null
+++ b/005-ffmpeg-add-svt-hevc-gb62f72e.patch
@@ -0,0 +1,20 @@
+--- a/010-ffmpeg-add-svt-hevc-gb62f72e.patch
++++ b/010-ffmpeg-add-svt-hevc-gb62f72e.patch
+@@ -46,14 +46,14 @@ index 5a167613a4..9897fcaf4d 100755
+ libxavs_encoder_deps="libxavs"
+ libxavs2_encoder_deps="libxavs2"
+ libxvid_encoder_deps="libxvid"
+-@@ -6686,6 +6689,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
++@@ -6757,6 +6757,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
+ check_lib mmal interface/mmal/mmal.h mmal_port_connect -lmmal_core -lmmal_util -lmmal_vc_client -lbcm_host; } ||
+ die "ERROR: mmal not found" &&
+ check_func_headers interface/mmal/mmal.h "MMAL_PARAMETER_VIDEO_MAX_NUM_CALLBACKS"; }
+ +enabled libsvthevc && require_pkg_config libsvthevc SvtHevcEnc EbApi.h EbInitHandle
+- enabled openal && { { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
++ enabled openal && { check_pkg_config openal "openal >= 1.1" "AL/al.h" alGetError ||
++ { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
+ check_lib openal 'AL/al.h' alGetError "${al_extralibs}" && break; done } ||
+- die "ERROR: openal not found"; } &&
+ diff --git a/libavcodec/Makefile b/libavcodec/Makefile
+ index 3b8f7b5e01..bfd6535345 100644
+ --- a/libavcodec/Makefile