summarylogtreecommitdiffstats
path: root/0061-disable-broken-gdbm-module.patch
diff options
context:
space:
mode:
Diffstat (limited to '0061-disable-broken-gdbm-module.patch')
-rw-r--r--0061-disable-broken-gdbm-module.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/0061-disable-broken-gdbm-module.patch b/0061-disable-broken-gdbm-module.patch
new file mode 100644
index 000000000000..5b3d26f49774
--- /dev/null
+++ b/0061-disable-broken-gdbm-module.patch
@@ -0,0 +1,29 @@
+From 391cfafdf3cd9cc56516cd6d3d8d37bf68ef870c Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Thu, 17 Jun 2021 18:52:15 +0530
+Subject: [PATCH 061/N] disable broken gdbm module
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Co-authored-by: Алексей <alexey.pawlow@gmail.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index ede0e72..74b844c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1405,7 +1405,7 @@ class PyBuildExt(build_ext):
+ if dbm_args:
+ dbm_order = [arg.split('=')[-1] for arg in dbm_args][-1].split(":")
+ else:
+- dbm_order = "ndbm:gdbm:bdb".split(":")
++ dbm_order = []
+ dbmext = None
+ for cand in dbm_order:
+ if cand == "ndbm":
+--
+2.33.0
+