summarylogtreecommitdiffstats
path: root/0064-disable-readline.patch
diff options
context:
space:
mode:
Diffstat (limited to '0064-disable-readline.patch')
-rw-r--r--0064-disable-readline.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/0064-disable-readline.patch b/0064-disable-readline.patch
new file mode 100644
index 000000000000..ee9b0494a8f0
--- /dev/null
+++ b/0064-disable-readline.patch
@@ -0,0 +1,32 @@
+From 7dc48f709c1ac3fd9d05b0f50ce4056bd3bf5268 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Thu, 17 Jun 2021 18:52:17 +0530
+Subject: [PATCH 064/N] disable readline
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Co-authored-by: Алексей <alexey.pawlow@gmail.com>
+---
+ setup.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index a4222fc..a4d206e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1003,7 +1003,10 @@ class PyBuildExt(build_ext):
+
+ def detect_readline_curses(self):
+ # readline
+- do_readline = self.compiler.find_library_file(self.lib_dirs, 'readline')
++ if not MS_WINDOWS:
++ do_readline = self.compiler.find_library_file(self.lib_dirs, 'readline')
++ else:
++ do_readline = False
+ readline_termcap_library = ""
+ curses_library = ""
+ # Cannot use os.popen here in py3k.
+--
+2.33.0
+