summarylogtreecommitdiffstats
path: root/010-ade-disable-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to '010-ade-disable-werror.patch')
-rw-r--r--010-ade-disable-werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/010-ade-disable-werror.patch b/010-ade-disable-werror.patch
new file mode 100644
index 000000000000..bc242009c94c
--- /dev/null
+++ b/010-ade-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/sources/ade/CMakeLists.txt
++++ b/sources/ade/CMakeLists.txt
+@@ -11,7 +11,7 @@ file( GLOB_RECURSE sources source/*.cpp )
+ file( GLOB_RECURSE include *.hpp )
+
+ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
+- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
++ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
+ endif()
+
+ add_library( ${PROJECT_NAME} STATIC ${include} ${sources} )