summarylogtreecommitdiffstats
path: root/010-qt-jpegxl-image-plugin-add-qt6-support.patch
diff options
context:
space:
mode:
Diffstat (limited to '010-qt-jpegxl-image-plugin-add-qt6-support.patch')
-rw-r--r--010-qt-jpegxl-image-plugin-add-qt6-support.patch13
1 files changed, 5 insertions, 8 deletions
diff --git a/010-qt-jpegxl-image-plugin-add-qt6-support.patch b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
index 335e3fa9c63d..2289df0af91a 100644
--- a/010-qt-jpegxl-image-plugin-add-qt6-support.patch
+++ b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
@@ -19,7 +19,7 @@
pkg_check_modules(LibJXL REQUIRED IMPORTED_TARGET libjxl>=0.5.0)
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -18,16 +18,16 @@ function(kimageformats_add_plugin plugin)
+@@ -18,7 +18,7 @@ function(kimageformats_add_plugin plugin)
add_library(${plugin} MODULE ${KIF_ADD_PLUGIN_SOURCES})
set_property(TARGET ${plugin} APPEND PROPERTY AUTOGEN_TARGET_DEPENDS ${json})
set_target_properties(${plugin} PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/imageformats")
@@ -28,15 +28,12 @@
install(TARGETS ${plugin} DESTINATION ${KDE_INSTALL_QTPLUGINDIR}/imageformats)
endfunction()
- ##################################
-
+@@ -27,7 +27,7 @@ endfunction()
if (LibJXL_FOUND)
-- kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
-- target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
+ kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
+ target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
- install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/)
-+ kimageformats_add_plugin(libqjpegxl-qt${QT_MAJOR} JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
-+ target_link_libraries(libqjpegxl-qt${QT_MAJOR} PkgConfig::LibJXL PkgConfig::LibJXLThreads)
-+ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl-qt${QT_MAJOR}.desktop)
++ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl_qt${QT_MAJOR}.desktop)
endif()
##################################