summarylogtreecommitdiffstats
path: root/013-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to '013-Makefile.patch')
-rw-r--r--013-Makefile.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/013-Makefile.patch b/013-Makefile.patch
deleted file mode 100644
index 30b44c7259fd..000000000000
--- a/013-Makefile.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/src/VBox/HostDrivers/linux/Makefile b/src/VBox/HostDrivers/linux/Makefile
-index 18466b48..7c7de4e5 100644
---- a/src/VBox/HostDrivers/linux/Makefile
-+++ b/src/VBox/HostDrivers/linux/Makefile
-@@ -23,25 +23,25 @@
- # terms and conditions of either the GPL or the CDDL or both.
- #
-
--ifneq ($(KERNELRELEASE),)
-+ifneq ($(KBUILD_EXTMOD),)
-
--# Building from kBuild (make -C <kernel_directory> M=`pwd`),
--# or inside a kernel source tree.
-+# Building from kBuild (make -C <kernel_directory> M=`pwd`).
-+# KBUILD_EXTMOD is set to $(M) in this case.
-
- obj-m = vboxdrv/
--ifneq ($(wildcard $(CURDIR)/vboxnetflt/Makefile),)
-+ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetflt/Makefile),)
- obj-m += vboxnetflt/
- endif
--ifneq ($(wildcard $(CURDIR)/vboxnetadp/Makefile),)
-+ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetadp/Makefile),)
- obj-m += vboxnetadp/
- endif
--ifneq ($(wildcard $(CURDIR)/vboxpci/Makefile),)
-+ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxpci/Makefile),)
- obj-m += vboxpci/
- endif
-
--else # ! KERNELRELEASE
-+else # ! KBUILD_EXTMOD
-
--# convenience Makefile without KERNELRELEASE
-+# convenience Makefile without KBUILD_EXTMOD
-
- KBUILD_VERBOSE ?=
- KERN_VER ?= $(shell uname -r)
-@@ -146,4 +146,4 @@ load: unload
- fi; \
- done
-
--endif # ! KERNELRELEASE
-+endif # ! KBUILD_EXTMOD