summarylogtreecommitdiffstats
path: root/013-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to '013-Makefile.patch')
-rw-r--r--013-Makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/013-Makefile.patch b/013-Makefile.patch
new file mode 100644
index 000000000000..5cabc5cb0d5e
--- /dev/null
+++ b/013-Makefile.patch
@@ -0,0 +1,42 @@
+--- a/src/vboxhost/Makefile
++++ b/src/vboxhost/Makefile
+@@ -23,25 +23,25 @@
+ # terms and conditions of either the GPL or the CDDL or both.
+ #
+
+-ifneq ($(KERNELRELEASE),)
++ifneq ($(KBUILD_EXTMOD),)
+
+-# Building from kBuild (make -C <kernel_directory> M=`pwd`),
+-# or inside a kernel source tree.
++# Building from kBuild (make -C <kernel_directory> M=`pwd`).
++# KBUILD_EXTMOD is set to $(M) in this case.
+
+ obj-m = vboxdrv/
+-ifneq ($(wildcard $(CURDIR)/vboxnetflt/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetflt/Makefile),)
+ obj-m += vboxnetflt/
+ endif
+-ifneq ($(wildcard $(CURDIR)/vboxnetadp/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetadp/Makefile),)
+ obj-m += vboxnetadp/
+ endif
+-ifneq ($(wildcard $(CURDIR)/vboxpci/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxpci/Makefile),)
+ obj-m += vboxpci/
+ endif
+
+-else # ! KERNELRELEASE
++else # ! KBUILD_EXTMOD
+
+-# convenience Makefile without KERNELRELEASE
++# convenience Makefile without KBUILD_EXTMOD
+
+ KBUILD_VERBOSE ?=
+ KERN_VER ?= $(shell uname -r)
+@@ -167,4 +167,4 @@ load: unload
+ fi; \
+ done
+
+-endif # ! KERNELRELEASE
++endif # ! KBUILD_EXTMOD