summarylogtreecommitdiffstats
path: root/02-Glitched-PDS-by-TkG.patch
diff options
context:
space:
mode:
Diffstat (limited to '02-Glitched-PDS-by-TkG.patch')
-rw-r--r--02-Glitched-PDS-by-TkG.patch96
1 files changed, 66 insertions, 30 deletions
diff --git a/02-Glitched-PDS-by-TkG.patch b/02-Glitched-PDS-by-TkG.patch
index c376e1cfc362..c556a1889696 100644
--- a/02-Glitched-PDS-by-TkG.patch
+++ b/02-Glitched-PDS-by-TkG.patch
@@ -162,34 +162,70 @@ index 20dcf19ea057627d91be07b4ec20f0827c30084c..24fa90ca63d144cc4f45d82d88407ea7
enum {
-diff --git a/init/Kconfig b/init/Kconfig
-index 11fd9b502d06..e9bc34d3019b 100644
---- a/init/Kconfig
-+++ b/init/Kconfig
-@@ -948,7 +948,6 @@ config CGROUP_DEVICE
-
- config CGROUP_CPUACCT
- bool "Simple CPU accounting controller"
+diff --git a/init/Kconfig b/init/Kconfig
+index 11fd9b502d06..e9bc34d3019b 100644
+--- a/init/Kconfig
++++ b/init/Kconfig
+@@ -948,7 +948,6 @@ config CGROUP_DEVICE
+
+ config CGROUP_CPUACCT
+ bool "Simple CPU accounting controller"
- depends on !SCHED_PDS
- help
- Provides a simple controller for monitoring the
- total CPU consumed by the tasks in a cgroup.
-diff --git a/kernel/sched/Makefile b/kernel/sched/Makefile
-index b23231bae996..cab4e5c5b38e 100644
---- a/kernel/sched/Makefile
-+++ b/kernel/sched/Makefile
-@@ -24,13 +24,13 @@ obj-y += fair.o rt.o deadline.o
- obj-$(CONFIG_SMP) += cpudeadline.o topology.o stop_task.o
- obj-$(CONFIG_SCHED_AUTOGROUP) += autogroup.o
- obj-$(CONFIG_SCHED_DEBUG) += debug.o
--obj-$(CONFIG_CGROUP_CPUACCT) += cpuacct.o
- endif
- obj-y += loadavg.o clock.o cputime.o
- obj-y += idle.o
- obj-y += wait.o wait_bit.o swait.o completion.o
- obj-$(CONFIG_SMP) += cpupri.o pelt.o
- obj-$(CONFIG_SCHEDSTATS) += stats.o
-+obj-$(CONFIG_CGROUP_CPUACCT) += cpuacct.o
- obj-$(CONFIG_CPU_FREQ) += cpufreq.o
- obj-$(CONFIG_CPU_FREQ_GOV_SCHEDUTIL) += cpufreq_schedutil.o
- obj-$(CONFIG_MEMBARRIER) += membarrier.o
+ help
+ Provides a simple controller for monitoring the
+ total CPU consumed by the tasks in a cgroup.
+diff --git a/kernel/sched/Makefile b/kernel/sched/Makefile
+index b23231bae996..cab4e5c5b38e 100644
+--- a/kernel/sched/Makefile
++++ b/kernel/sched/Makefile
+@@ -24,13 +24,13 @@ obj-y += fair.o rt.o deadline.o
+ obj-$(CONFIG_SMP) += cpudeadline.o topology.o stop_task.o
+ obj-$(CONFIG_SCHED_AUTOGROUP) += autogroup.o
+ obj-$(CONFIG_SCHED_DEBUG) += debug.o
+-obj-$(CONFIG_CGROUP_CPUACCT) += cpuacct.o
+ endif
+ obj-y += loadavg.o clock.o cputime.o
+ obj-y += idle.o
+ obj-y += wait.o wait_bit.o swait.o completion.o
+ obj-$(CONFIG_SMP) += cpupri.o pelt.o
+ obj-$(CONFIG_SCHEDSTATS) += stats.o
++obj-$(CONFIG_CGROUP_CPUACCT) += cpuacct.o
+ obj-$(CONFIG_CPU_FREQ) += cpufreq.o
+ obj-$(CONFIG_CPU_FREQ_GOV_SCHEDUTIL) += cpufreq_schedutil.o
+ obj-$(CONFIG_MEMBARRIER) += membarrier.o
+
+diff --git a/kernel/sched/pds.c b/kernel/sched/pds.c
+index 9281ad164..f09a609cf 100644
+--- a/kernel/sched/pds.c
++++ b/kernel/sched/pds.c
+@@ -81,6 +81,18 @@ enum {
+ NR_CPU_AFFINITY_CHK_LEVEL
+ };
+
++/*
++ * This allows printing both to /proc/sched_debug and
++ * to the console
++ */
++#define SEQ_printf(m, x...) \
++ do { \
++ if (m) \
++ seq_printf(m, x); \
++ else \
++ pr_cont(x); \
++ } while (0)
++
+ static inline void print_scheduler_version(void)
+ {
+ printk(KERN_INFO "pds: PDS-mq CPU Scheduler 0.99o by Alfred Chen.\n");
+@@ -6353,7 +6365,10 @@ void ia64_set_curr_task(int cpu, struct task_struct *p)
+ #ifdef CONFIG_SCHED_DEBUG
+ void proc_sched_show_task(struct task_struct *p, struct pid_namespace *ns,
+ struct seq_file *m)
+-{}
++{
++ SEQ_printf(m, "%s (%d, #threads: %d)\n", p->comm, task_pid_nr_ns(p, ns),
++ get_nr_threads(p));
++}
+
+ void proc_sched_set_task(struct task_struct *p)
+ {}