summarylogtreecommitdiffstats
path: root/06_always-disable-valgrind.patch
diff options
context:
space:
mode:
Diffstat (limited to '06_always-disable-valgrind.patch')
-rw-r--r--06_always-disable-valgrind.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/06_always-disable-valgrind.patch b/06_always-disable-valgrind.patch
new file mode 100644
index 000000000000..8c7d96c7204f
--- /dev/null
+++ b/06_always-disable-valgrind.patch
@@ -0,0 +1,17 @@
+Description: Always disable valgrind tests
+Origin: vendor
+Bug-Debian: http://bugs.debian.org/690968
+Forwarded: not-needed
+Last-Update: 2012-10-22
+
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -57,7 +57,7 @@
+ if CROSSCOMPILING
+ TEST = @echo "NOTICE: we can't run the tests when cross-compiling!"
+ else # if not cross-compiling:
+-TEST = srcdir=$(srcdir) $(PERL) $(PERLFLAGS) $(srcdir)/runtests.pl
++TEST = srcdir=$(srcdir) $(PERL) $(PERLFLAGS) $(srcdir)/runtests.pl -n
+ TEST_Q = -a -s
+ TEST_AM = -a -am
+ TEST_F = -a -p -r