summarylogtreecommitdiffstats
path: root/11_dont_touch_po_files.patch
diff options
context:
space:
mode:
Diffstat (limited to '11_dont_touch_po_files.patch')
-rw-r--r--11_dont_touch_po_files.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/11_dont_touch_po_files.patch b/11_dont_touch_po_files.patch
new file mode 100644
index 000000000000..0289150d410e
--- /dev/null
+++ b/11_dont_touch_po_files.patch
@@ -0,0 +1,31 @@
+Do not update po files upon building and installing binaries.
+Use a separate target instead.
+
+Index: cpufrequtils/Makefile
+===================================================================
+--- cpufrequtils.orig/Makefile 2012-05-06 14:55:18.445553259 +0900
++++ cpufrequtils/Makefile 2012-05-06 14:55:26.589398186 +0900
+@@ -211,9 +211,9 @@
+ test -f $(PACKAGE).po && \
+ mv -f $(PACKAGE).po po/$(PACKAGE).pot
+
+-update-gmo: po/$(PACKAGE).pot
++update-po: po/$(PACKAGE).pot
+ @for HLANG in $(LANGUAGES); do \
+- echo -n "Translating $$HLANG "; \
++ echo -n "Updating $$HLANG "; \
+ if msgmerge po/$$HLANG.po po/$(PACKAGE).pot -o \
+ po/$$HLANG.new.po; then \
+ mv -f po/$$HLANG.new.po po/$$HLANG.po; \
+@@ -221,6 +221,11 @@
+ echo "msgmerge for $$HLANG failed!"; \
+ rm -f po/$$HLANG.new.po; \
+ fi; \
++ done;
++
++update-gmo: po/$(PACKAGE).pot
++ @for HLANG in $(LANGUAGES); do \
++ echo -n "Translating $$HLANG "; \
+ msgfmt --statistics -o po/$$HLANG.gmo po/$$HLANG.po; \
+ done;
+