summarylogtreecommitdiffstats
path: root/140-nvidia-open-gcc-sls.patch
diff options
context:
space:
mode:
Diffstat (limited to '140-nvidia-open-gcc-sls.patch')
-rw-r--r--140-nvidia-open-gcc-sls.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/140-nvidia-open-gcc-sls.patch b/140-nvidia-open-gcc-sls.patch
new file mode 100644
index 000000000000..258026c64a72
--- /dev/null
+++ b/140-nvidia-open-gcc-sls.patch
@@ -0,0 +1,10 @@
+--- a/src/nvidia-modeset/Makefile
++++ b/src/nvidia-modeset/Makefile
+@@ -142,6 +142,7 @@ ifeq ($(TARGET_ARCH),x86_64)
+ CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -fno-jump-tables)
+ CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mindirect-branch=thunk-extern)
+ CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mindirect-branch-register)
++ CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mharden-sls=all)
+ endif
+
+ CFLAGS += $(CONDITIONAL_CFLAGS)