summarylogtreecommitdiffstats
path: root/141.patch
diff options
context:
space:
mode:
Diffstat (limited to '141.patch')
-rw-r--r--141.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/141.patch b/141.patch
new file mode 100644
index 000000000000..79712d765637
--- /dev/null
+++ b/141.patch
@@ -0,0 +1,53 @@
+From b9e828fea104e23bd52e936e15d51d2ce7f44fae Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Wed, 27 May 2020 12:27:44 -0700
+Subject: [PATCH 1/2] Find console_bridge 1.0 if 0.3 is not found
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 92762f1..87d0ce6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -41,7 +41,10 @@ if (NOT MSVC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ endif()
+
+-find_package(console_bridge 0.3 REQUIRED)
++find_package(console_bridge 0.3 QUIET)
++if (NOT console_bridge_FOUND)
++ find_package(console_bridge 1.0 REQUIRED)
++endif()
+ include_directories(SYSTEM ${console_bridge_INCLUDE_DIRS})
+ link_directories(${console_bridge_LIBRARY_DIRS})
+
+
+From b18a97b4bb2767de29c014b5d84941f5adade29f Mon Sep 17 00:00:00 2001
+From: Steven Peters <scpeters@openrobotics.org>
+Date: Wed, 27 May 2020 15:40:27 -0700
+Subject: [PATCH 2/2] just drop explicit version requirement
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ CMakeLists.txt | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 87d0ce6..f0d115d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -41,10 +41,7 @@ if (NOT MSVC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ endif()
+
+-find_package(console_bridge 0.3 QUIET)
+-if (NOT console_bridge_FOUND)
+- find_package(console_bridge 1.0 REQUIRED)
+-endif()
++find_package(console_bridge REQUIRED)
+ include_directories(SYSTEM ${console_bridge_INCLUDE_DIRS})
+ link_directories(${console_bridge_LIBRARY_DIRS})
+