summarylogtreecommitdiffstats
path: root/2001_system_graphite2_support.patch
diff options
context:
space:
mode:
Diffstat (limited to '2001_system_graphite2_support.patch')
-rw-r--r--2001_system_graphite2_support.patch86
1 files changed, 23 insertions, 63 deletions
diff --git a/2001_system_graphite2_support.patch b/2001_system_graphite2_support.patch
index 1ba176d080b8..b83cb466f2e5 100644
--- a/2001_system_graphite2_support.patch
+++ b/2001_system_graphite2_support.patch
@@ -103,14 +103,9 @@ diff --git a/gfx/graphite2/moz-gr-update.sh b/gfx/graphite2/moz-gr-update.sh
diff --git a/gfx/moz.build b/gfx/moz.build
--- a/gfx/moz.build
+++ b/gfx/moz.build
-@@ -8,28 +8,32 @@ with Files('**'):
- BUG_COMPONENT = ('Core', 'Graphics')
- SCHEDULES.inclusive += ['android-hw-gfx']
- with Files('wr/**'):
- BUG_COMPONENT = ('Core', 'Graphics: WebRender')
-
- if CONFIG['MOZ_TREE_CAIRO']:
- DIRS += ['cairo']
+@@ -13,6 +13,11 @@
+ if CONFIG["MOZ_TREE_CAIRO"]:
+ DIRS += ["cairo"]
+if CONFIG['MOZ_SYSTEM_GRAPHITE2']:
+ DIRS += ['graphite2/geckoextra']
@@ -120,47 +115,29 @@ diff --git a/gfx/moz.build b/gfx/moz.build
if not CONFIG['MOZ_SYSTEM_HARFBUZZ']:
DIRS += ['harfbuzz/src']
- DIRS += [
- '2d',
- 'ycbcr',
- 'angle',
- 'src',
- 'qcms',
- 'gl',
- 'layers',
-- 'graphite2/src',
- 'ots/src',
- 'thebes',
- 'ipc',
- 'vr',
- 'config',
- 'webrender_bindings',
- 'wgpu_bindings',
- ]
+@@ -24,7 +29,6 @@
+ "qcms",
+ "gl",
+ "layers",
+- "graphite2/src",
+ "ots/src",
+ "thebes",
+ "ipc",
diff --git a/gfx/thebes/moz.build b/gfx/thebes/moz.build
--- a/gfx/thebes/moz.build
+++ b/gfx/thebes/moz.build
-@@ -283,16 +283,19 @@ if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('and
- if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'gtk':
- CXXFLAGS += CONFIG['MOZ_PANGO_CFLAGS']
-
- if CONFIG['MOZ_WAYLAND']:
- CXXFLAGS += CONFIG['MOZ_WAYLAND_CFLAGS']
+@@ -287,7 +287,10 @@
- LOCAL_INCLUDES += CONFIG['SKIA_INCLUDES']
+ LOCAL_INCLUDES += CONFIG["SKIA_INCLUDES"]
--DEFINES['GRAPHITE2_STATIC'] = True
+-DEFINES["GRAPHITE2_STATIC"] = True
+if CONFIG['MOZ_SYSTEM_GRAPHITE2']:
+ CXXFLAGS += CONFIG['MOZ_GRAPHITE2_CFLAGS']
+else:
-+ DEFINES['GRAPHITE2_STATIC'] = True
++ DEFINES["GRAPHITE2_STATIC"] = True
if CONFIG['MOZ_SYSTEM_HARFBUZZ']:
CXXFLAGS += CONFIG['MOZ_HARFBUZZ_CFLAGS']
-
- if CONFIG['CC_TYPE'] == 'clang':
- # Suppress warnings from Skia header files.
- SOURCES['gfxPlatform.cpp'].flags += ['-Wno-implicit-fallthrough']
diff --git a/old-configure.in b/old-configure.in
--- a/old-configure.in
+++ b/old-configure.in
@@ -205,14 +182,9 @@ diff --git a/old-configure.in b/old-configure.in
diff --git a/toolkit/library/moz.build b/toolkit/library/moz.build
--- a/toolkit/library/moz.build
+++ b/toolkit/library/moz.build
-@@ -234,16 +234,19 @@ if CONFIG['MOZ_ANDROID_GOOGLE_VR']:
- OS_LIBS += [
- '-L%s' % CONFIG['MOZ_ANDROID_GOOGLE_VR_LIBS'],
- '-lgvr',
- ]
-
- OS_LIBS += CONFIG['MOZ_CAIRO_OSLIBS']
- OS_LIBS += CONFIG['MOZ_WEBRTC_X11_LIBS']
+@@ -238,6 +238,9 @@
+ OS_LIBS += CONFIG["MOZ_CAIRO_OSLIBS"]
+ OS_LIBS += CONFIG["MOZ_WEBRTC_X11_LIBS"]
+if CONFIG['MOZ_SYSTEM_GRAPHITE2']:
+ OS_LIBS += CONFIG['MOZ_GRAPHITE2_LIBS']
@@ -220,22 +192,12 @@ diff --git a/toolkit/library/moz.build b/toolkit/library/moz.build
if CONFIG['MOZ_SYSTEM_HARFBUZZ']:
OS_LIBS += CONFIG['MOZ_HARFBUZZ_LIBS']
- if CONFIG['MOZ_SYSTEM_JPEG']:
- OS_LIBS += CONFIG['MOZ_JPEG_LIBS']
-
- if CONFIG['MOZ_SYSTEM_PNG']:
- OS_LIBS += CONFIG['MOZ_PNG_LIBS']
diff --git a/toolkit/moz.configure b/toolkit/moz.configure
--- a/toolkit/moz.configure
+++ b/toolkit/moz.configure
-@@ -397,16 +397,30 @@ def freetype2_combined_info(fontconfig_i
- return namespace(
- cflags=freetype2_info.cflags + fontconfig_info.cflags,
- libs=freetype2_info.libs + fontconfig_info.libs,
- )
-
- add_old_configure_assignment('_HAVE_FREETYPE2',
- depends_if(freetype2_info)(lambda _: True))
+@@ -475,6 +475,21 @@
+ "_HAVE_FREETYPE2", depends_if(freetype2_info)(lambda _: True)
+ )
+# Graphite2
+# ==============================================================
@@ -251,11 +213,9 @@ diff --git a/toolkit/moz.configure b/toolkit/moz.configure
+
+set_config('MOZ_SYSTEM_GRAPHITE2', depends_if(system_graphite2)(lambda _: True))
+
++
# HarfBuzz
# ==============================================================
option('--with-system-harfbuzz',
- help="Use system harfbuzz (located with pkgconfig)")
-
- system_harfbuzz = pkg_check_modules('MOZ_HARFBUZZ', 'harfbuzz >= 2.3.1',
- when='--with-system-harfbuzz')
+