summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--patch.patch44
3 files changed, 50 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e01a6a2c0ce..72c64a8d14f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = 0ad-git
pkgdesc = Cross-platform, 3D and historically-based real-time strategy game - built from git development version.
- pkgver = A26.r1310.g899a956de4
+ pkgver = A26.r1378.ge1cea2a398
pkgrel = 1
epoch = 1
url = http://play0ad.com/
@@ -14,37 +14,33 @@ pkgbase = 0ad-git
makedepends = zip
makedepends = libsm
makedepends = rust
+ makedepends = python311
makedepends = python
makedepends = git
makedepends = enet
makedepends = fmt
makedepends = gloox
- makedepends = glu
- makedepends = libgl
makedepends = libminiupnpc.so
- makedepends = libogg
makedepends = libpng
makedepends = libsodium
makedepends = libvorbis
makedepends = miniupnpc
- makedepends = nspr
makedepends = openal
makedepends = sdl2
makedepends = wxwidgets-gtk3
+ makedepends = which
options = !lto
options = !debug
source = git+https://github.com/0ad/0ad.git
source = patch.patch
md5sums = SKIP
- md5sums = dcbd62e1fb4669c24318c8fe66143c4f
+ md5sums = 0c789b7aa65258125a488c857e3fb74b
pkgname = 0ad-git
depends = 0ad-data
- depends = binutils
depends = boost-libs
depends = curl
depends = enet
- depends = libogg
depends = libpng
depends = libvorbis
depends = libxml2
@@ -52,14 +48,11 @@ pkgname = 0ad-git
depends = sdl2
depends = wxwidgets-gtk3
depends = zlib
- depends = libgl
- depends = glu
depends = fmt
depends = gloox
depends = miniupnpc
depends = libminiupnpc.so
depends = icu
- depends = nspr
depends = libsodium
depends = which
provides = 0ad
diff --git a/PKGBUILD b/PKGBUILD
index 7136455b3561..29f00359f57d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,19 @@
pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
epoch=1
-pkgver=A26.r1310.g899a956de4
+pkgver=A26.r1378.ge1cea2a398
pkgrel=1
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game - built from git development version."
arch=('i686' 'x86_64')
url="http://play0ad.com/"
license=('GPL-2.0-or-later' 'CCPL')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python' 'git'
- 'enet' 'fmt' 'gloox' 'glu' 'libgl' 'libminiupnpc.so' 'libogg'
- 'libpng' 'libsodium' 'libvorbis' 'miniupnpc' 'nspr' 'openal'
- 'sdl2' 'wxwidgets-gtk3')
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python311' 'python' 'git'
+ 'enet' 'fmt' 'gloox' 'libminiupnpc.so'
+ 'libpng' 'libsodium' 'libvorbis' 'miniupnpc' 'openal'
+ 'sdl2' 'wxwidgets-gtk3' 'which')
options=('!lto' '!debug') # lto breaks spidermonkey linking (https://bugs.gentoo.org/746947)
source=("git+https://github.com/0ad/0ad.git" "patch.patch")
-md5sums=('SKIP' 'dcbd62e1fb4669c24318c8fe66143c4f')
+md5sums=('SKIP' '0c789b7aa65258125a488c857e3fb74b')
pkgver() {
cd ${_pkgname}
@@ -28,9 +28,7 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
- # fix for error:
- # source/ps/Util.cpp:27:1: note: ‘std::setfill’ is defined in header ‘<iomanip>’; did you forget to ‘#include <iomanip>’?
- patch -p1 -i ../patch.patch
+ patch -p1 -i ../patch.patch # Fix build with GCC 14
}
@@ -40,6 +38,8 @@ build() {
# this uses malloc_usable_size, which is incompatible with fortification level 3
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+ # remove once this is fixed https://trac.wildfiregames.com/ticket/6895
+ export PYTHON3=python3.11
./update-workspaces.sh \
--without-pch \
@@ -65,9 +65,9 @@ build() {
}
package_0ad-git() {
- depends=('0ad-data' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
- 'libxml2' 'openal' 'sdl2' 'wxwidgets-gtk3' 'zlib' 'libgl' 'glu' 'fmt'
- 'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium' 'which')
+ depends=('0ad-data' 'boost-libs' 'curl' 'enet' 'libpng' 'libvorbis'
+ 'libxml2' 'openal' 'sdl2' 'wxwidgets-gtk3' 'zlib' 'fmt'
+ 'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'libsodium' 'which')
conflicts=('0ad')
provides=('0ad')
diff --git a/patch.patch b/patch.patch
index 6e8121a3d311..db37b4e73873 100644
--- a/patch.patch
+++ b/patch.patch
@@ -1,10 +1,34 @@
---- a/source/ps/Util.cpp
-+++ b/source/ps/Util.cpp
-@@ -24,6 +24,7 @@
- #include "ps/CLogger.h"
- #include "ps/Filesystem.h"
- #include "ps/Pyrogenesis.h"
-+#include <iomanip>
-
- // not thread-safe!
- static const wchar_t* HardcodedErrorString(int err)
+diff -Nurp 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/config.h 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/config.h
+--- 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/config.h 2024-05-18 00:49:34.826020244 +0200
++++ 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/config.h 2024-05-18 01:00:06.205846962 +0200
+@@ -24,7 +24,7 @@
+ #define HAVE_MOVEFILEEXA
+ #endif
+ /* #undef HAVE_STRINGS_H */
+-/* #undef HAVE_UNISTD_H */
++#define HAVE_UNISTD_H
+ #define __INT8_LIBZIP 1
+ #define INT8_T_LIBZIP 1
+ #define UINT8_T_LIBZIP 1
+diff -Nurp 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/mkstemp.c 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/mkstemp.c
+--- 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/mkstemp.c 2022-08-21 14:46:10.000000000 +0200
++++ 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/mkstemp.c 2024-05-18 00:51:50.581458274 +0200
+@@ -43,6 +43,7 @@
+ #endif
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #ifndef O_BINARY
+ #define O_BINARY 0
+diff -Nurp 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/zip_fdopen.c 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/zip_fdopen.c
+--- 0ad-0.0.26-alpha/build/premake/premake5/contrib/libzip/zip_fdopen.c 2022-08-21 14:46:10.000000000 +0200
++++ 0ad-0.0.26-alpha-ziplib/build/premake/premake5/contrib/libzip/zip_fdopen.c 2024-05-18 00:59:22.412174372 +0200
+@@ -34,6 +34,7 @@
+
+
+ #include "zipint.h"
++#include <unistd.h>
+
+
+