summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--1panel.install4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/1panel.install b/1panel.install
index c6bed080dc1c..b7abdcfc1493 100644
--- a/1panel.install
+++ b/1panel.install
@@ -37,12 +37,12 @@ post_install() {
# 判断docker和docker-compose安装
if pacman -Qs docker >/dev/null 2>&1; then
echo -e "Docker is installed correctly."
- else:
+ else
echo -e "\033[31mWarning: Docker is not installed, please install it, or most of the features of this package will not be available.\033[0m"
fi
if pacman -Qs docker-compose >/dev/null 2>&1; then
echo -e "Docker Compose is installed correctly."
- else:
+ else
echo -e "\033[31mWarning: Docker Compose is not installed, please install it, or 1Panel application store will not be avaliable.\033[0m"
fi
unset _1panel_active_interface
diff --git a/PKGBUILD b/PKGBUILD
index a334654cf280..602295d116dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,9 +30,13 @@ source=(
"${pkgname}"::"git+https://github.com/1Panel-dev/1Panel.git#branch=dev"
"1panel.service"
)
-sha256sums=("SKIP")
+sha256sums=(
+ "SKIP"
+ "1d85c0b4a0b7256c75bb14d10d2bfb29fdcfb4c7ebc99622b024bd61be314ea3"
+)
build() {
+ # Override the upstream 1pctl script
echo "#!/bin/bash" > ${srcdir}/1pctl
echo "BASE_DIR=/opt" >> ${srcdir}/1pctl
echo "ORIGINAL_PORT=${_1panel_original_port}" >> ${srcdir}/1pctl
@@ -40,10 +44,10 @@ build() {
echo "ORIGINAL_ENTRANCE=${_1panel_original_entrance}" >> ${srcdir}/1pctl
echo "ORIGINAL_USERNAME=${_1panel_original_username}" >> ${srcdir}/1pctl
echo "ORIGINAL_PASSWORD=${_1panel_original_password}" >> ${srcdir}/1pctl
- # Override the upstream 1pctl script
+ echo "1panel --help" >> ${srcdir}/1pctl
+ # Compile 1Panel using Makefile
cd ${srcdir}/${pkgname}
make build_all
-
}
package() {