summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c467a2494944
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = 2048.cpp-git
+ pkgdesc = Fully featured terminal version of the game 2048 written in C++
+ pkgver = r362.50bd8a7
+ pkgrel = 1
+ url = https://github.com/plibither8/2048.cpp
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ conflicts = 2048.c
+ conflicts = 2048.c-git
+ conflicts = 2048-cli-git
+ conflicts = 2048-curses
+ conflicts = 2048-rs
+ source = git+https://github.com/plibither8/2048.cpp.git
+ sha1sums = SKIP
+
+pkgname = 2048.cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aed74019a626
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+
+_pkgname=2048.cpp
+pkgname=${_pkgname}-git
+pkgver=r362.50bd8a7
+pkgrel=1
+pkgdesc="Fully featured terminal version of the game "2048" written in C++ "
+arch=('any')
+url="https://github.com/plibither8/2048.cpp"
+license=('MIT')
+makedepends=('git' 'cmake')
+source=("git+https://github.com/plibither8/2048.cpp.git")
+sha1sums=('SKIP')
+
+conflicts=("2048.c" "2048.c-git" "2048-cli-git" "2048-curses" "2048-rs")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake .
+ cmake --build .
+}
+
+package() {
+ install "${srcdir}/${_pkgname}/2048" -D "${pkgdir}/usr/bin/2048"
+}
+
+