summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a73d43c5f78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = 3mf2stl
+ pkgdesc = Convert 3mf files to stl
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/lemgandi/3mf2stl
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ depends = libzip
+ provides = 3mf2stl
+ source = git+https://github.com/lemgandi/3mf2stl.git
+ md5sums = SKIP
+
+pkgname = 3mf2stl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..129fccd88be6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luke Johnston <lukejohnston at outlook dot com>
+pkgname="3mf2stl"
+pkgver=1.0
+pkgrel=1
+pkgdesc="Convert 3mf files to stl"
+depends=("gcc-libs" "libzip")
+arch=("x86_64")
+url="https://github.com/lemgandi/3mf2stl"
+source=("git+https://github.com/lemgandi/3mf2stl.git")
+license=("GPL3")
+provides=("3mf2stl")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/3mf2stl"
+ make
+}
+
+package() {
+ cd "${srcdir}/3mf2stl"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp 3mf2stl "${pkgdir}/usr/bin"
+}