summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edf1d61adf9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = 3to2
+ pkgdesc = Script to convert python3 code to python2. Counterpart to 2to3
+ pkgver = 1.0
+ pkgrel = 4
+ url = https://bitbucket.org/amentajo/lib3to2
+ arch = any
+ license = Apache
+ makedepends = mercurial
+ depends = python2
+ source = https://bitbucket.org/amentajo/lib3to2/downloads/3to2-1.0.tar.gz
+ md5sums = c23a3841fdd5ca0493533c74d6c4de5c
+
+pkgname = 3to2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43400951938e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Andreas Theodosiou <andreasabu at gmail dot com>
+# Contributor: Jarek Sedlacek <jareksedlacek at gmail dot com>
+
+pkgname=3to2
+pkgver=1.0
+pkgrel=4
+pkgdesc="Script to convert python3 code to python2. Counterpart to 2to3"
+arch=('any')
+license=('Apache')
+url='https://bitbucket.org/amentajo/lib3to2'
+depends=('python2')
+makedepends=('mercurial')
+source=("https://bitbucket.org/amentajo/lib3to2/downloads/3to2-$pkgver.tar.gz")
+noextract=()
+md5sums=('c23a3841fdd5ca0493533c74d6c4de5c')
+
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./setup.py install --root=$pkgdir/ --optimize=1
+}