summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--4l.install6
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c8ae88708c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = 4l
+ pkgdesc = 4L: LaCie LightScribe Labeler for Linux
+ pkgver = 1.0r6
+ pkgrel = 6
+ url = http://www.lacie.com/products/product.htm?pid=10803
+ install = 4l.install
+ arch = i686
+ license = unknown
+ makedepends = rpmextract
+ depends = gcc-libs
+ depends = libxi
+ depends = fontconfig
+ depends = libxinerama
+ depends = libxcursor
+ depends = libxrandr
+ depends = lightscribe
+ source = http://www.lacie.com/download/drivers/4L-1.0-r6.i586.rpm
+ md5sums = 11fc8b2daeaed2b61a567056413bdefd
+
+pkgname = 4l
+
diff --git a/4l.install b/4l.install
new file mode 100644
index 000000000000..d8052e42cd98
--- /dev/null
+++ b/4l.install
@@ -0,0 +1,6 @@
+
+post_install() {
+ echo "Don't forget to edit /etc/lightscribe.rc"
+}
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ef842c452cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Imanol Celaya <ilcra1989@gmail.com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=4l
+pkgver=1.0r6
+_realname=4L-1.0-r6
+pkgrel=6
+pkgdesc="4L: LaCie LightScribe Labeler for Linux"
+arch=('i686')
+url="http://www.lacie.com/products/product.htm?pid=10803"
+license=('unknown')
+install=4l.install
+depends=('gcc-libs' 'libxi' 'fontconfig' 'libxinerama' 'libxcursor' 'libxrandr' 'lightscribe')
+makedepends=('rpmextract')
+source=(http://www.lacie.com/download/drivers/$_realname.i586.rpm)
+md5sums=('11fc8b2daeaed2b61a567056413bdefd')
+
+package() {
+ cd $srcdir
+ rpmextract.sh 4L-1.0-r6.i586.rpm 2> /dev/null
+ mkdir -p $pkgdir/{opt,usr/bin}
+ cp -R usr/4L $pkgdir/opt
+ #cd ${pkgdir}/usr/bin
+ ln -s /opt/4L/4L-cli ${pkgdir}/usr/bin/4L-cli
+ ln -s /opt/4L/4L-gui ${pkgdir}/usr/bin/4L-gui
+ find $pkgdir/opt -type d -exec chmod 755 {} \;
+ chmod -x $pkgdir/opt/4L/*/*
+ chmod +s $pkgdir/opt/4L/4L-cli
+}