summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d6770259111
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = 4suite
+ pkgdesc = A platform for XML processing and knowledge-management
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = http://foursuite.sourceforge.net/
+ arch = any
+ license = GPL
+ depends = python2
+ source = http://downloads.sourceforge.net/sourceforge/foursuite/4Suite-XML-1.0.2.tar.bz2
+ md5sums = b3e976a666899113d58f333518205968
+
+pkgname = 4suite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7eac80d27ad9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=4suite
+pkgver=1.0.2
+pkgrel=2
+pkgdesc="A platform for XML processing and knowledge-management"
+arch=('any')
+url="http://foursuite.sourceforge.net/"
+depends=('python2')
+license=('GPL')
+source=(http://downloads.sourceforge.net/sourceforge/foursuite/4Suite-XML-${pkgver}.tar.bz2)
+md5sums=('b3e976a666899113d58f333518205968')
+
+package() {
+ cd "${srcdir}"/4Suite-XML-${pkgver}
+
+ python2 setup.py install --root="${pkgdir}" --system
+
+# python fix
+ cd "${pkgdir}"/usr/bin
+
+ for file in $(find . -name '4x*' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+}