summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rwxr-xr-xfiller.sh89
3 files changed, 109 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 360064a30535..2c4637411026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Aug 28 08:54:14 UTC 2017
pkgbase = 602xmlfiller
- pkgdesc = Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment
+ pkgdesc = Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment. Without bundled Wine.
pkgver = 4.52.0.3_13.0725
- pkgrel = 1
- url = http://www.602.eu/form-filler
+ pkgrel = 2
+ url = https://www.602.cz/o-nas/ke-stazeni/aktualni-produkty/form-filler/
arch = i686
arch = x86_64
license = custom
depends = nss
+ depends = wine
+ source = filler.sh
+ md5sums = de5790c5d990f43119fd1282fc1545d6
pkgname = 602xmlfiller
diff --git a/PKGBUILD b/PKGBUILD
index 1b3dd6292354..02c06ce6239e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Contributor: Jakub Bittner, vlastikcz
+# Contributor: Jakub Bittner, vlastikcz, mezcal, Mario Hros
pkgname=602xmlfiller
pkgver=4.52.0.3_13.0725
-pkgrel=1
-pkgdesc="Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment"
-url="http://www.602.eu/form-filler"
+pkgrel=2
+pkgdesc="Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment. Without bundled Wine."
+url="https://www.602.cz/o-nas/ke-stazeni/aktualni-produkty/form-filler/"
arch=('i686' 'x86_64')
license=('custom')
-depends=('nss')
+depends=('nss' 'wine')
if [[ $CARCH == 'i686' ]]; then
source=("$pkgname-$pkgver.deb::http://www.602.cz/download/602xml/RPM/kub11/Software602_Form_Filler.deb")
@@ -15,7 +15,10 @@ elif [[ $CARCH == 'x86_64' ]]; then
source=("$pkgname_x64-$pkgver.deb::http://www.602.cz/download/602xml/RPM/kub11_x64/Software602_Form_Filler.deb")
md5sums=('a13159d7a74b9dffe436beeccaa0dc2b')
fi
-
+
+source+=('filler.sh')
+md5sums+=('de5790c5d990f43119fd1282fc1545d6')
+
build() {
tar -xf data.tar.gz
@@ -23,4 +26,7 @@ build() {
package() {
cp -dr --no-preserve=ownership usr "$pkgdir/"
+ rm -rf "$pkgdir/usr/lib/602filler/"{bin,lib,share} "$pkgdir/usr/lib/602filler/.wine/lib"
+ install -Dm755 "$srcdir/filler.sh" "$pkgdir/usr/bin/filler.sh"
}
+
diff --git a/filler.sh b/filler.sh
new file mode 100755
index 000000000000..2dc7ca09a2a5
--- /dev/null
+++ b/filler.sh
@@ -0,0 +1,89 @@
+#!/bin/sh
+# Executes 602XML Filler with specified parameters
+# echo "$@"
+WHOME="$HOME"/.602filler
+OHOME=/usr/lib/602filler/.wine
+
+test -d $WHOME && test ! -e $WHOME/.debrelloc && rm -rf $WHOME/drive_c/windows && rm -rf $WHOME/drive_c/openssl && rm -rf $WHOME/drive_c/Program\ Files
+test ! -d $WHOME && mkdir $WHOME
+test ! -e $WHOME/.debrelloc && touch $WHOME/.debrelloc
+test ! -e $WHOME/user.reg && cp $OHOME/user.reg $WHOME
+test ! -e $WHOME/userdef.reg && cp $OHOME/userdef.reg $WHOME
+#test ! -e $WHOME/system.reg && cp $OHOME/system.reg $WHOME
+cp $OHOME/system.reg $WHOME
+test ! -e $WHOME/.update-timestamp && cp $OHOME/.update-timestamp $WHOME
+
+test ! -d $WHOME/drive_c && test -e $WHOME/drive_c && rm -rf $WHOME/drive_c
+test ! -d $WHOME/drive_c && mkdir $WHOME/drive_c
+
+#openssl config and random data because of Ubuntu 10.10
+test ! -d $WHOME/drive_c/openssl && mkdir $WHOME/drive_c/openssl
+test ! -e $WHOME/drive_c/openssl/openssl.cnf && ln -s $OHOME/drive_c/Program\ Files/Software602/602XML/Xmlcore/openssl.cnf $WHOME/drive_c/openssl/openssl.cnf
+test -e $WHOME/drive_c/.rnd && rm $WHOME/drive_c/.rnd
+cp $OHOME/drive_c/.rnd $WHOME/drive_c/.rnd
+
+test ! -d $WHOME/dosdevices && mkdir $WHOME/dosdevices
+test -e $WHOME/dosdevices/c\: && rm $WHOME/dosdevices/c\:
+ln -s $WHOME/drive_c/ $WHOME/dosdevices/c:
+test ! -e $WHOME/dosdevices/x\: && ln -s /tmp/ $WHOME/dosdevices/x:
+test ! -e $WHOME/dosdevices/y\: && ln -s $HOME/ $WHOME/dosdevices/y:
+test ! -e $WHOME/dosdevices/z\: && ln -s / $WHOME/dosdevices/z:
+
+test -e $WHOME/drive_c/Program\ Files && rm -rf $WHOME/drive_c/Program\ Files
+ln -s $OHOME/drive_c/Program\ Files/ $WHOME/drive_c/Program\ Files
+
+test -e $WHOME/drive_c/windows && rm -rf $WHOME/drive_c/windows
+mkdir $WHOME/drive_c/windows
+#link files
+#ln -s $OHOME/drive_c/windows/acrorun.exe $WHOME/drive_c/windows/acrorun.exe
+ln -s $OHOME/drive_c/windows/explorer.exe $WHOME/drive_c/windows/explorer.exe
+ln -s $OHOME/drive_c/windows/hh.exe $WHOME/drive_c/windows/hh.exe
+#ln -s $OHOME/drive_c/windows/notepad.exe $WHOME/drive_c/windows/notepad.exe
+ln -s $OHOME/drive_c/windows/printer.reg $WHOME/drive_c/windows/printer.reg
+ln -s $OHOME/drive_c/windows/regedit.exe $WHOME/drive_c/windows/regedit.exe
+ln -s $OHOME/drive_c/windows/rundll32.exe $WHOME/drive_c/windows/rundll32.exe
+ln -s $OHOME/drive_c/windows/twain_32.dll $WHOME/drive_c/windows/twain_32.dll
+ln -s $OHOME/drive_c/windows/winebrowser.exe $WHOME/drive_c/windows/winebrowser.exe
+ln -s $OHOME/drive_c/windows/winhelp.exe $WHOME/drive_c/windows/winhelp.exe
+ln -s $OHOME/drive_c/windows/winhlp32.exe $WHOME/drive_c/windows/winhlp32.exe
+#link dirs
+ln -s $OHOME/drive_c/windows/command $WHOME/drive_c/windows/command
+#ln -s $OHOME/drive_c/windows/Fonts $WHOME/drive_c/windows/Fonts
+ln -s $OHOME/drive_c/windows/fonts $WHOME/drive_c/windows/fonts
+ln -s $OHOME/drive_c/windows/inf $WHOME/drive_c/windows/inf
+#ln -s $OHOME/drive_c/windows/profiles $WHOME/drive_c/windows/profiles
+#ln -s $OHOME/drive_c/windows/system $WHOME/drive_c/windows/system
+ln -s $OHOME/drive_c/windows/system32 $WHOME/drive_c/windows/system32
+ln -s $OHOME/drive_c/windows/winsxs $WHOME/drive_c/windows/winsxs
+#copy files
+cp -pr $OHOME/drive_c/windows/system.ini $WHOME/drive_c/windows/
+cp -pr $OHOME/drive_c/windows/win.ini $WHOME/drive_c/windows/
+chmod 644 $WHOME/drive_c/windows/system.ini
+chmod 644 $WHOME/drive_c/windows/win.ini
+
+#create temp dir
+mkdir $WHOME/drive_c/windows/temp
+test ! -e $WHOME/drive_c/windows/temp/BinFiles602 && mkdir $WHOME/drive_c/windows/temp/BinFiles602 && chmod 700 $WHOME/drive_c/windows/temp/BinFiles602
+
+#test for user profile temp
+test -e $WHOME/drive_c/profiles/$USER && {
+ test -e $WHOME/drive_c/profiles/$USER/Temp && \
+ rm -rf $WHOME/drive_c/profiles/$USER/Temp && \
+ mkdir $WHOME/drive_c/profiles/$USER/Temp
+}
+
+#end of creating WHOME - ~/.602filler
+
+#profile might be accessed only by user
+chmod -R 700 $WHOME
+
+#nastaveni wine a spusteni fillera
+IDIR="/usr/lib/602filler"
+export WINEPREFIX="$WHOME"
+#export WINESERVER="$IDIR/bin/wineserver"
+#export WINELOADER="$IDIR/bin/wine"
+#export WINEDLLPATH="$IDIR/lib/wine"
+export WINEDLLOVERRIDES="mshtml=;winemenubuilder.exe=;"
+#export WINEDEBUG="-all"
+#export LD_LIBRARY_PATH="$IDIR/lib;$WHOME/lib;/usr/lib/nss"
+wine ~/.602filler/drive_c/Program\ Files/Software602/602XML/Filler/filler602.exe "$@"