summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x8085-simulator10
-rw-r--r--8085-simulator.desktop3
-rw-r--r--PKGBUILD10
3 files changed, 16 insertions, 7 deletions
diff --git a/8085-simulator b/8085-simulator
index 359aa6a18c2d..bcb9fb1469ae 100755
--- a/8085-simulator
+++ b/8085-simulator
@@ -1,3 +1,13 @@
#!/bin/bash
+# Lauch the java program
java -jar /opt/8085-simulator/8085-simulator-2.0.jar
+
+# This program creates some data files in the working directory.
+#
+# - settings.dat
+# - backup.dat
+# - *\user_code (directory)
+#
+# Delete these unwanted files upon exit
+rm -rf settings.dat backup.dat *\\user_code
diff --git a/8085-simulator.desktop b/8085-simulator.desktop
index f15508e2e857..0a7fe29d6fef 100644
--- a/8085-simulator.desktop
+++ b/8085-simulator.desktop
@@ -2,6 +2,5 @@
Name=8085 Simulator
Type=Application
Exec=8085-simulator
-Terminal=false
-Comment=Jubin's 8085 Simulator with Training Kit
+Comment=Jubin's 8085 Simulator with Trainer Kit
Categories=Education;Engineering;Science;Development;Programming;
diff --git a/PKGBUILD b/PKGBUILD
index a2c2fba3e6a1..1b318a2c0ee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=8085-simulator
pkgver=2.0
-pkgrel=1
-pkgdesc="Jubin's 8085 Simulator with Training Kit, written in Java"
+pkgrel=2
+pkgdesc="Jubin's 8085 Simulator with Trainer Kit, written in Java"
arch=('any')
url="https://8085simulator.codeplex.com"
license=('GPL2')
depends=('java-runtime')
install=
changelog=
-source=("${pkgname}-${pkgver}.jar::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=8085simulator&DownloadId=87364&FileTime=130460912818130000&Build=21024"
+source=("${pkgname}-${pkgver}.jar::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=8085simulator&DownloadId=87364&FileTime=130460912818130000&Build=21028"
"${pkgname}"
"${pkgname}.desktop")
noextract=("8085-simulator-2.0.jar")
sha256sums=("9ca0323f74e9cf5db13476a65c563bcf52ebf13dceb92a1f472b6d35bf7dd01e"
- "449c1dabed9d2a7e0689420a79975d6b6734842a91e4dfccfedbe223402ebd0a"
- "30385a84b5f6cebd78cc7e770ce74f2a9f6271e4000dfb676da0e36f7451c0be")
+ "3f0a6856e16655e53ef70780a73fdfa516db2dc1c5be5727e3477087f5d77f32"
+ "596e4a94073169a2d5e10f2dee9109a9646f64172b5af258beafe043ad273e76")
package() {
msg2 "Copying source files..."