summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rwxr-xr-x8085-simulator3
-rw-r--r--8085-simulator.desktop7
-rw-r--r--PKGBUILD30
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b997f4780cc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = 8085-simulator
+ pkgdesc = Jubin's 8085 Simulator with Training Kit
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://8085simulator.codeplex.com
+ arch = any
+ license = GPL2
+ depends = java-runtime
+ noextract = 8085-simulator-2.0.jar
+ source = 8085-simulator-2.0.jar::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=8085simulator&DownloadId=87364&FileTime=130460912818130000&Build=21024
+ source = 8085-simulator
+ source = 8085-simulator.desktop
+ sha256sums = 9ca0323f74e9cf5db13476a65c563bcf52ebf13dceb92a1f472b6d35bf7dd01e
+ sha256sums = 449c1dabed9d2a7e0689420a79975d6b6734842a91e4dfccfedbe223402ebd0a
+ sha256sums = 30385a84b5f6cebd78cc7e770ce74f2a9f6271e4000dfb676da0e36f7451c0be
+
+pkgname = 8085-simulator
+
diff --git a/8085-simulator b/8085-simulator
new file mode 100755
index 000000000000..359aa6a18c2d
--- /dev/null
+++ b/8085-simulator
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+java -jar /opt/8085-simulator/8085-simulator-2.0.jar
diff --git a/8085-simulator.desktop b/8085-simulator.desktop
new file mode 100644
index 000000000000..f15508e2e857
--- /dev/null
+++ b/8085-simulator.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=8085 Simulator
+Type=Application
+Exec=8085-simulator
+Terminal=false
+Comment=Jubin's 8085 Simulator with Training Kit
+Categories=Education;Engineering;Science;Development;Programming;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d5c3e56eb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Manish Munikar <munikarmanish at gmail dot com>
+
+pkgname=8085-simulator
+pkgver=2.0
+pkgrel=1
+pkgdesc="Jubin's 8085 Simulator with Training Kit"
+arch=('any')
+url="https://8085simulator.codeplex.com"
+license=('GPL2')
+depends=('java-runtime')
+install=
+changelog=
+source=("${pkgname}-${pkgver}.jar::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=8085simulator&DownloadId=87364&FileTime=130460912818130000&Build=21024"
+ "${pkgname}"
+ "${pkgname}.desktop")
+noextract=("8085-simulator-2.0.jar")
+sha256sums=("9ca0323f74e9cf5db13476a65c563bcf52ebf13dceb92a1f472b6d35bf7dd01e"
+ "449c1dabed9d2a7e0689420a79975d6b6734842a91e4dfccfedbe223402ebd0a"
+ "30385a84b5f6cebd78cc7e770ce74f2a9f6271e4000dfb676da0e36f7451c0be")
+
+package() {
+ msg2 "Copying source files..."
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}.jar" "${pkgdir}/opt/${pkgname}/${pkgname}-${pkgver}.jar"
+
+ msg2 "Creating executable file..."
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ msg2 "Creating desktop entry..."
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}