summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--86Box.desktop10
-rw-r--r--86box2
-rw-r--r--PKGBUILD20
4 files changed, 12 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c011d241f4..a8fa443e9170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 86box
pkgdesc = An emulator for classic IBM PC clones
- pkgver = 3.3
- pkgrel = 4
+ pkgver = 3.4
+ pkgrel = 1
url = https://86box.net/
arch = pentium4
arch = x86_64
@@ -24,11 +24,7 @@ pkgbase = 86box
optdepends = discord-game-sdk: Discord Rich Presence
optdepends = libpcap: Networking not limited to TCP/IP
options = !buildflags
- source = https://github.com/86Box/86Box/archive/refs/tags/v3.3.tar.gz
- source = 86box
- source = 86Box.desktop
- sha512sums = c590b138d4cb19519847f13d8d68d6d8a54ee2372cb00e998dbb9b15d6c18beaa2e842625631fa716c1dba49149f1a93e8f6521a02d05d97b91ca311b8d91859
- sha512sums = 827735339dc28aedc98b5427e19b8234d9db41095307ef2614aa9a1272af14f624b7d8d314f891b7e91a606bf54e94713663abed93f0f1429ce988eecca50f18
- sha512sums = 143447f38e3ddf458f469dffd37897503112100cf69d46dbe6810f5e64c32d91d87dcb46fe4447cda8d2fb91dd2f1b868ee1e43575a972280801b40cf7cfbd85
+ source = https://github.com/86Box/86Box/archive/refs/tags/v3.4.tar.gz
+ sha512sums = a60034e027bd188343c8eaefe6c56699bf5f7b8016cb1443b081655377bddbd84159cd63362d268a73fc6a5f92ec38544d2fb82aacdb40e8d0eec83bba00cff0
pkgname = 86box
diff --git a/86Box.desktop b/86Box.desktop
deleted file mode 100644
index c4119b2b8c7b..000000000000
--- a/86Box.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=
-Encoding=UTF-8
-Name=86Box
-Exec=/usr/bin/86box -P ~/.config/86box
-Terminal=true
-Type=Application
-Icon=86Box
-Comment=Emulator of x86-based machines.
-Categories=System;
diff --git a/86box b/86box
deleted file mode 100644
index b48bad96e664..000000000000
--- a/86box
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-86Box -R /usr/share/86Box/roms "$@"
diff --git a/PKGBUILD b/PKGBUILD
index 2c3417ff8741..ecdecac872b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: oscareczek <oscareczek at gmail dot com>
pkgname=86box
_pkgname=86Box
-pkgver=3.3
-pkgrel=4
+pkgver=3.4
+pkgrel=1
pkgdesc='An emulator for classic IBM PC clones'
arch=('pentium4' 'x86_64' 'arm7h' 'aarch64')
url='https://86box.net/'
@@ -17,14 +17,8 @@ optdepends=(
options=('!buildflags')
source=(
"https://github.com/${_pkgname}/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
- '86box'
- '86Box.desktop'
-)
-sha512sums=(
- 'c590b138d4cb19519847f13d8d68d6d8a54ee2372cb00e998dbb9b15d6c18beaa2e842625631fa716c1dba49149f1a93e8f6521a02d05d97b91ca311b8d91859'
- '827735339dc28aedc98b5427e19b8234d9db41095307ef2614aa9a1272af14f624b7d8d314f891b7e91a606bf54e94713663abed93f0f1429ce988eecca50f18'
- '143447f38e3ddf458f469dffd37897503112100cf69d46dbe6810f5e64c32d91d87dcb46fe4447cda8d2fb91dd2f1b868ee1e43575a972280801b40cf7cfbd85'
)
+sha512sums=('a60034e027bd188343c8eaefe6c56699bf5f7b8016cb1443b081655377bddbd84159cd63362d268a73fc6a5f92ec38544d2fb82aacdb40e8d0eec83bba00cff0')
build() {
case "$CARCH" in
@@ -39,7 +33,9 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --build "${srcdir}/build" --target install
- install -Dm755 86box "$pkgdir/usr/bin"
- install -Dm644 86Box.desktop -t "$pkgdir/usr/share/applications"
- install -Dm644 "$srcdir/$_pkgname-$pkgver/src/win/assets/86Box-green.png" "$pkgdir/usr/share/pixmaps/86Box.png"
+ for i in 48x48 64x64 72x72 96x96 128x128 192x192 256x256 512x512; do
+ install -Dm644 "$srcdir/$_pkgname-$pkgver/src/unix/assets/$i/net.86box.86Box.png" -t "$pkgdir/usr/share/icons/hicolor/$i/apps"
+ done
+ mkdir "$pkgdir/usr/share/applications"
+ sed 's/^Exec.*/Exec=86Box -P .local\/share\/86Box/' "$srcdir/$_pkgname-$pkgver/src/unix/assets/net.86box.86Box.desktop" > "$pkgdir/usr/share/applications/net.86box.86Box.desktop"
}