summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..158a28a29a26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = a-john-shots
+ pkgdesc = A tool to get the Security Hash Algorightms (SHA) of all file in a given path.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/funilrys/A-John-Shots
+ arch = any
+ license = MIT
+ depends = python3
+ depends = python-setuptools
+ depends = python-colorama
+ source = https://files.pythonhosted.org/packages/source/a/a-john-shots/a-john-shots-2.0.0.tar.gz
+ source = https://raw.githubusercontent.com/funilrys/A-John-Shots/master/LICENSE
+ sha256sums = a5f2aa947b847acf1d5252c4be38e118c9d273961eb3bdaea9b40e521c81f8d9
+ sha256sums = 1a1b0133c4abf0795a5d861a6832374d1e74e268f81b9164d6106f461342caff
+
+pkgname = a-john-shots
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..575f6c568368
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nissar Chababy <contact at funilrys dot com>
+
+pkgname="a-john-shots"
+_name=${pkgname}
+upstreamName=${pkgname}
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A tool to get the Security Hash Algorightms (SHA) of all file in a given path."
+arch=('any')
+url="https://github.com/funilrys/A-John-Shots"
+license=('MIT')
+depends=(
+ 'python3'
+ 'python-setuptools'
+ 'python-colorama'
+)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${upstreamName}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/funilrys/A-John-Shots/master/LICENSE"
+)
+sha256sums=(
+ "a5f2aa947b847acf1d5252c4be38e118c9d273961eb3bdaea9b40e521c81f8d9"
+ "1a1b0133c4abf0795a5d861a6832374d1e74e268f81b9164d6106f461342caff"
+)
+
+build() {
+ cd ${srcdir}/${upstreamName}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${srcdir}/${upstreamName}-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}