summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 31 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fea809900f25..197210b9388a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = aarch64-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the ARM64 target
- pkgver = 2.38
- pkgrel = 1
+ pkgver = 2.40
+ pkgrel = 3
url = https://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
- depends = zlib
- depends = elfutils
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.38.tar.xz
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.38.tar.xz.sig
+ makedepends = git
+ depends = libelf
+ depends = jansson
+ depends = perl
+ source = git+https://sourceware.org/git/binutils-gdb.git#commit=594dcc92e8d1f6bb30e3dfa4eb343febcda66f1a
+ validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
- sha256sums = e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024
sha256sums = SKIP
pkgname = aarch64-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 21c02e58e16c..09d9af73cee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,42 @@
_arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-binutils
-pkgver=2.38
-pkgrel=1
+pkgver=2.40
+pkgrel=3
+_commit=594dcc92e8d1f6bb30e3dfa4eb343febcda66f1a
pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM64 target'
arch=('x86_64')
url='https://www.gnu.org/software/binutils/'
license=(GPL)
-depends=('zlib' 'elfutils')
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
-sha256sums=('e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024'
- 'SKIP')
+depends=('libelf' 'jansson' 'perl')
+makedepends=('git')
+source=(git+https://sourceware.org/git/binutils-gdb.git#commit=${_commit})
+sha256sums=('SKIP')
-validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
+ '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
+
+prepare() {
+ mkdir -p binutils-build
+}
build() {
- cd binutils-$pkgver
+ cd binutils-build
- ./configure \
+ "$srcdir"/binutils-gdb/configure \
--target=$_target \
--with-sysroot=/usr/$_target/sys-root \
--prefix=/usr \
+ --enable-colored-disassembly \
+ --enable-default-execstack=no \
--enable-deterministic-archives \
--enable-gold \
--enable-install-libiberty \
+ --enable-jansson \
--enable-ld=default \
- --enable-lto \
+ --enable-new-dtags \
--enable-plugins \
--enable-relro \
- --enable-shared \
--enable-threads \
--disable-gdb \
--disable-gdbserver \
@@ -41,16 +49,17 @@ build() {
--disable-werror \
--with-debuginfod \
--with-pic \
- --with-system-zlib
+ --with-system-zlib \
make
}
package() {
- cd binutils-$pkgver
+ cd binutils-build
make DESTDIR="$pkgdir" install
# Remove files that conflict with host version
- rm -r "$pkgdir"/usr/{include,lib,share}
+ rm -rf "$pkgdir"/usr/{etc,include,lib,share}
}
+