summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64f096d3abcf..d172f8d5fc59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = aarch64-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the ARM64 target
pkgver = 2.37
- pkgrel = 0
+ pkgrel = 1
url = https://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
- depends = libelf
depends = zlib
+ depends = elfutils
source = https://ftp.gnu.org/gnu/binutils/binutils-2.37.tar.xz
source = https://ftp.gnu.org/gnu/binutils/binutils-2.37.tar.xz.sig
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
diff --git a/PKGBUILD b/PKGBUILD
index c59610aaf393..9ca4e1f9df6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
-# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
-# Contributor: Christer Solskogen <christer.solskogen@gmail.com>
+# Maintainer: Christer Solskogen <christer.solskogen@gmail.com>
# Build order: aarch64-binutils -> aarch64-linux-api-headers -> aarch64-gcc-bootstrap -> aarch64-glibc -> aarch64-gcc -> aarch64-glibc (again)
_arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-binutils
pkgver=2.37
-pkgrel=0
+pkgrel=1
pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM64 target'
-arch=(x86_64)
+arch=('x86_64')
url='https://www.gnu.org/software/binutils/'
license=(GPL)
-depends=('libelf' 'zlib')
+depends=('zlib' 'elfutils')
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
sha256sums=('820d9724f020a3e69cb337893a0b63c2db161dadcb0e06fc11dc29eb1e84a32c'
'SKIP')
@@ -41,7 +40,7 @@ build() {
check() {
cd binutils-$pkgver
- make
+ make -k check || true
}
package() {
@@ -49,13 +48,6 @@ package() {
make DESTDIR="$pkgdir" install
- # Replace hard links with symlinks
- for file in $(ls "$pkgdir"/usr/$_target/bin)
- do
- rm "$pkgdir"/usr/$_target/bin/$file
- ln -sv ../../bin/$_target-$file "$pkgdir"/usr/$_target/bin/$file
- done
-
# Remove file conflicting with host binutils and manpages for MS Windows tools
rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*