summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--configure.sh20
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7ed90d5f34d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aarch64-linux-gnu-configure
+ pkgdesc = A configure wrapper for the ARM64 target
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://fedoraproject.org/wiki/MinGW
+ arch = x86_64
+ license = GPL
+ depends = aarch64-linux-gnu-gcc
+ depends = aarch64-linux-gnu-pkg-config
+ depends = aarch64-linux-gnu-environment
+ source = configure.sh
+ sha256sums = bf13d26c868e66341770002dd3e3c6a77b10f453bc2b43dda477e2827d5172e0
+
+pkgname = aarch64-linux-gnu-configure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..398d5ccb81e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Tilmann Meyer <tilmann.meyer@gmx.net>
+
+_target=aarch64-linux-gnu
+
+pkgname=$_target-configure
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A configure wrapper for the ARM64 target'
+arch=(x86_64)
+url='http://fedoraproject.org/wiki/MinGW'
+license=(GPL)
+depends=($_target-gcc $_target-pkg-config $_target-environment)
+makedepends=()
+options=()
+source=('configure.sh')
+sha256sums=('bf13d26c868e66341770002dd3e3c6a77b10f453bc2b43dda477e2827d5172e0')
+
+package() {
+ install -m 755 -D configure.sh "$pkgdir"/usr/bin/$_target-configure
+}
diff --git a/configure.sh b/configure.sh
new file mode 100644
index 000000000000..9e36d43022d5
--- /dev/null
+++ b/configure.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+TARGET=aarch64-linux-gnu
+
+PREFIX=/usr/$TARGET
+
+source $TARGET-environment
+
+# check if last arg is a path to configure, else use parent
+for last; do true; done
+if test -x "${last}/configure"; then
+ config_path="$last"
+else
+ config_path=".."
+fi
+
+${config_path}/configure \
+ --host=$TARGET --target=$TARGET --build="$CHOST" \
+ --prefix=$PREFIX \
+ --enable-shared --enable-static "$@"