summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
-rw-r--r--aarchup.install16
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb62fe6d268f..a7b0b86c1f59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aarchup
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 1.7.4
+ pkgver = 1.8
pkgrel = 1
url = https://github.com/aericson/aarchup
install = aarchup.install
@@ -15,8 +15,8 @@ pkgbase = aarchup
depends = gtk2
optdepends = cower: AUR support(--aur)
backup = etc/systemd/system/aarchup.timer
- source = https://github.com/aericson/aarchup/archive/1.7.4.zip
- md5sums = d64d1eb513e311409be5cb240b2c0831
+ source = https://github.com/aericson/aarchup/archive/1.8.zip
+ md5sums = 241a6580515a1996588082fa25ceddd7
pkgname = aarchup
diff --git a/PKGBUILD b/PKGBUILD
index c5064ed88a21..0112c6ee7cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: aericson <de.ericson@gmail.com>
pkgname=aarchup
-pkgver=1.7.4
+pkgver=1.8
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
url="https://github.com/aericson/aarchup"
@@ -12,24 +12,24 @@ license="GPL"
depends=('pacman' 'libnotify' 'gtk2')
makedepends=('libnotify' 'autoconf' 'gzip')
source=("https://github.com/aericson/aarchup/archive/$pkgver.zip")
-md5sums=('d64d1eb513e311409be5cb240b2c0831')
+md5sums=('241a6580515a1996588082fa25ceddd7')
backup=('etc/systemd/system/aarchup.timer')
optdepends=('cower: AUR support(--aur)')
install='aarchup.install'
prepare() {
- mv -v $pkgname-$pkgver/src/* $pkgname-$pkgver/
- rmdir $pkgname-$pkgver/src
+ mv -v $pkgname-$pkgver/src/* $pkgname-$pkgver/
+ rmdir $pkgname-$pkgver/src
}
build() {
- cd $pkgname-$pkgver/
- autoconf || return 1
- ./configure --prefix=/usr || return 1
- make || return 1
+ cd $pkgname-$pkgver/
+ autoconf || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
}
package() {
- cd $pkgname-$pkgver/
- make DESTDIR="$pkgdir/" install || return 1
+ cd $pkgname-$pkgver/
+ make DESTDIR="$pkgdir/" install || return 1
}
diff --git a/aarchup.install b/aarchup.install
index 0085d4ff41de..6f84814c2369 100644
--- a/aarchup.install
+++ b/aarchup.install
@@ -1,15 +1,19 @@
post_upgrade() {
cat << EOF
- Crontab is no longer supported. The prefered method is still with --loop-time.
- Alternatively you can use systemd timer included in the package. Please see man aarchup.
- If you wish to use the systemd timer you can set the time frequency on the file /etc/systemd/system/aarchup.timer
+ To avoid problems with partial upgrades (http://gist.io/5660494) we no longer
+ use the combination of pacman -Sy/-Qu to check for updates.
+
+ As a result of this --ignore-disconnect was removed. Please remove it from your configurations, if you were using it.
+
+ If you were using --command|-c, note that the command has to check for updates now
+ since we no longer call pacman -Sy.
EOF
}
post_install() {
cat <<EOF
- Please check man pages for installation instructions.
- If you have any problems or would like to request a feature,
- check https://bbs.archlinux.org/viewtopic.php?id=119129
+ Please check man pages for installation instructions.
+ If you have any problems or would like to request a feature,
+ check https://bbs.archlinux.org/viewtopic.php?id=119129
EOF
}