summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-aarchup.c-switch-to-auracle-sync.patch68
-rw-r--r--PKGBUILD47
2 files changed, 96 insertions, 19 deletions
diff --git a/0001-aarchup.c-switch-to-auracle-sync.patch b/0001-aarchup.c-switch-to-auracle-sync.patch
new file mode 100644
index 000000000000..724bee138f93
--- /dev/null
+++ b/0001-aarchup.c-switch-to-auracle-sync.patch
@@ -0,0 +1,68 @@
+From 658412ac9603bfbf1a49c7c6e5cf23becb79dc38 Mon Sep 17 00:00:00 2001
+From: Alad Wenter <alad@mailbox.org>
+Date: Fri, 9 Feb 2018 02:26:20 +0100
+Subject: [PATCH] aarchup.c: switch to "auracle sync"
+
+More efficient replacement of cower by the same author.
+---
+ aarchup.c | 18 ++++++++----------
+ 1 file changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/aarchup.c b/aarchup.c
+index e3840eb..bbce913 100644
+--- a/aarchup.c
++++ b/aarchup.c
+@@ -31,15 +31,13 @@
+ #define VERSION_NUMBER "1.8.1"
+
+
+-/* Parse cower -u output.
+- * Format: ":: package_name version -> new_version" */
++/* Parse auracle sync output.
++ * Format: "package_name version -> new_version" */
+ void parse(char *line){
+ int i, j;
+ int llen = strlen(line);
+- /* Find first space */
+- for(i=0;!isspace(line[i]) && i < llen; ++i);
+ /* Copy package_name */
+- for(j=0, ++i;!isspace(line[i]) && i < llen;++j, ++i)
++ for(j=0, i=0;!isspace(line[i]) && i < llen;++j, ++i)
+ line[j] = line[i];
+ i = llen - 1;
+ line[j++] = ' ';
+@@ -236,7 +234,7 @@ int print_help(char *name)
+ printf(" For more information on it check man.\n");
+ printf(" --help Prints this help.\n");
+ printf(" --version Shows the version.\n");
+- printf(" --aur Check aur for new packages too. Will need cower installed.\n");
++ printf(" --aur Check aur for new packages too. Will need auracle installed.\n");
+ printf(" --debug|-d Print debug info.\n");
+ printf(" --ftimeout|-f [value] Program will manually enforce timeout for closing notification.\n");
+ printf(" Do NOT use with --timeout, if --timeout works or without --loop-time [value].\n");
+@@ -503,7 +501,7 @@ int main(int argc, char **argv)
+ /* Those are needed by libnotify. */
+ char *name = "New Updates";
+ char *category = "update";
+- char *cower = "cower -u";
++ char *auracle = "auracle sync";
+ NotifyNotification *my_notify = NULL;
+
+ /* Those are needed for the output. */
+@@ -574,10 +572,10 @@ int main(int argc, char **argv)
+ if(aur && i < max_number_out){
+ if(debug)
+ printf("DEBUG(info): aur is on, checking for updates in aur\n");
+- /* call cower */
++ /* call auracle */
+ if(debug)
+- printf("DEBUG(info): running command: %s\n", cower);
+- pac_out = popen(cower, "r");
++ printf("DEBUG(info): running command: %s\n", auracle);
++ pac_out = popen(auracle, "r");
+ if(ignore_pkg_flag)
+ IgnorePkg = get_ignore_pkgs(&ign_pkg_size,debug);
+
+--
+2.16.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 03f5dfc20dcf..8b75af6fe5ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,44 @@
-# Contributor: Rorschach <r0rschach@lavabit.com>
-# Contributor: Andrew Kravchuk <awkravchuk@gmail.com>
-# Contributor: aericson <de.ericson@gmail.com>
-
-pkgname=aarchup
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: aericson <de.ericson at gmail dot com>
+# Contributor: Rorschach <r0rschach at lavabit dot com>
+# Contributor: Andrew Kravchuk <awkravchuk at gmail dot com>
+#
+pkgname="aarchup"
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
url="https://github.com/aericson/aarchup"
arch=('i686' 'x86_64')
-license=('GPL')
-depends=('pacman' 'libnotify' 'gtk2')
+license=('GPL3')
+provides=("${pkgname}")
+depends=('libnotify' 'gtk2')
makedepends=('libnotify' 'autoconf' 'gzip')
-source=("https://github.com/aericson/aarchup/archive/$pkgver.zip")
-md5sums=('b68cb385795dddc7d748842084336ab7')
backup=('etc/systemd/system/aarchup.timer')
-optdepends=('cower: AUR support(--aur)')
+optdepends=('auracle: AUR support(--aur)')
install='aarchup.install'
+source=("${pkgname}-${pkgver}.zip::${url}/archive/${pkgver}.zip"
+ '0001-aarchup.c-switch-to-auracle-sync.patch'
+)
+sha256sums=('9d96df312502ac61379678a7297dd1c40b045709054c66691e3680fa389096fe'
+ 'e1d0e0cacabd2f13be23a570320fbad37619d6f752e524f94e791871c7ca28b6')
prepare() {
- mv -v $pkgname-$pkgver/src/* $pkgname-$pkgver/
- rmdir $pkgname-$pkgver/src
+ mv -v "${pkgname}-${pkgver}"/src/* "${pkgname}-${pkgver}"
+ rmdir "${pkgname}-${pkgver}"/src
}
build() {
- cd $pkgname-$pkgver/
- autoconf || return 1
- ./configure --prefix=/usr || return 1
- make || return 1
+ cd "${pkgname}-${pkgver}"
+ patch -p1 < ../0001-aarchup.c-switch-to-auracle-sync.patch
+ autoconf
+ ./configure --prefix=/usr
+ make
}
package() {
- cd $pkgname-$pkgver/
- make DESTDIR="$pkgdir/" install || return 1
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
+
+# vim: set ts=4 sw=4 et syn=sh ft=sh: