summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--aarchup.install19
3 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba13e358ab4..21dbd88fe91c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = aarchup-git
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 1.8.3.r1.g598d1e5
+ pkgver = 2.1.7
pkgrel = 1
- url = https://github.com/aericson/aarchup
- install = aarchup.install
+ url = https://github.com/inglor/aarchup
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = cmake
+ makedepends = meson
+ makedepends = ninja
depends = libnotify
depends = gtk2
optdepends = auracle: AUR support(--aur)
provides = aarchup
conflicts = aarchup
- backup = usr/lib/systemd/system/aarchup.timer
- source = git+https://github.com/stefanhusmann/aarchup.git
+ source = git+https://gitlab.com/artafinde/aarchup.git
md5sums = SKIP
pkgname = aarchup-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b974efd853b9..3ed83acdc374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,19 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=aarchup-git
-pkgver=1.8.3.r1.g598d1e5
+pkgver=2.1.7
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
-url="https://github.com/aericson/aarchup"
+url="https://github.com/inglor/aarchup"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libnotify' 'gtk2')
-makedepends=('git')
-source=("git+https://github.com/stefanhusmann/aarchup.git")
+makedepends=('git' 'cmake' 'meson' 'ninja')
+source=("git+https://gitlab.com/artafinde/aarchup.git")
md5sums=('SKIP')
-backup=('usr/lib/systemd/system/aarchup.timer')
conflicts=('aarchup')
provides=('aarchup')
optdepends=('auracle: AUR support(--aur)')
-install=aarchup.install
pkgver() {
cd ${pkgname%-git}
@@ -26,13 +24,12 @@ pkgver() {
}
build() {
- cd ${pkgname%-git}/src
- autoconf
- ./configure --prefix=/usr
- make
+ cd ${pkgname%-git}
+ meson --prefix=/usr --buildtype=plain . build
+ meson compile -C build
}
package() {
- cd ${pkgname%-git}/src
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname%-git}
+ DESTDIR="$pkgdir/" ninja install -C build
}
diff --git a/aarchup.install b/aarchup.install
deleted file mode 100644
index 2eafe0eb4a84..000000000000
--- a/aarchup.install
+++ /dev/null
@@ -1,19 +0,0 @@
-post_upgrade() {
- cat << EOF
- To avoid problems with partial upgrades (http://gist.io/5660494) we no longer
- use the combination of pacman -Sy/-Qu to check for updates. We now use checkupdates.
-
- As a result of this --ignore-disconnect was removed. Please remove it from your configurations, if you were using it.
-
- If you were using --command|-c, note that the command has to check for updates now
- since we no longer call pacman -Sy.
-EOF
-}
-
-post_install() {
- cat <<EOF
- Please check man pages for installation instructions.
- If you have any problems or would like to request a feature,
- check https://bbs.archlinux.org/viewtopic.php?id=119129
-EOF
-}