summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba13e358ab4..9f57475999b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = aarchup-git
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 1.8.3.r1.g598d1e5
+ pkgver = 2.1.0.r1.ga8e4cf5
pkgrel = 1
- url = https://github.com/aericson/aarchup
+ url = https://github.com/inglor/aarchup
install = aarchup.install
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = cmake
+ makedepends = ninja
depends = libnotify
depends = gtk2
optdepends = auracle: AUR support(--aur)
provides = aarchup
conflicts = aarchup
- backup = usr/lib/systemd/system/aarchup.timer
- source = git+https://github.com/stefanhusmann/aarchup.git
+ source = git+https://github.com/inglor/aarchup.git
md5sums = SKIP
pkgname = aarchup-git
diff --git a/PKGBUILD b/PKGBUILD
index b974efd853b9..aed7b24ae7af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,16 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=aarchup-git
-pkgver=1.8.3.r1.g598d1e5
+pkgver=2.1.0.r1.ga8e4cf5
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
-url="https://github.com/aericson/aarchup"
+url="https://github.com/inglor/aarchup"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libnotify' 'gtk2')
-makedepends=('git')
-source=("git+https://github.com/stefanhusmann/aarchup.git")
+makedepends=('git' 'cmake' 'ninja')
+source=("git+https://github.com/inglor/aarchup.git")
md5sums=('SKIP')
-backup=('usr/lib/systemd/system/aarchup.timer')
conflicts=('aarchup')
provides=('aarchup')
optdepends=('auracle: AUR support(--aur)')
@@ -27,12 +26,13 @@ pkgver() {
build() {
cd ${pkgname%-git}/src
- autoconf
- ./configure --prefix=/usr
- make
+ cmake .. -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ ninja all
}
package() {
cd ${pkgname%-git}/src
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja install
}