summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--abnt2-ext.install10
-rw-r--r--abnt2_ext59
-rw-r--r--abnt2ext59
5 files changed, 78 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffa801f7fbf3..b0557f217d63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = abnt2-ext
pkgdesc = ABNT2 extended keyboard
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/kugland/abnt2-ext-arch
+ install = abnt2-ext.install
arch = any
license = GPL
depends = xkeyboard-config
depends = python-lxml
- source = abnt2_ext
+ source = abnt2ext
source = patch_evdev.py
source = abnt2-patch-evdev.hook
- sha256sums = c5f1cfe3cabb17c0912409fa9c283a360a7d1ae9407751b484b5c2b7f8f48c01
+ sha256sums = 1cb4058afc71968999b188ddd99813a9faaa0baf38cacd7e81f5e048186dfb67
sha256sums = 74194d63c9bde72e8cd9a4c05d2711cda99a2208bc0ce43b0d6973aaae5edee3
sha256sums = cc2b039de1cf0f6e179a3fdb9c6c9959626e9378343388aadf63e05a3f2fc93a
diff --git a/PKGBUILD b/PKGBUILD
index 3d9ef02daffa..4c79b1942f03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=abnt2-ext
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="ABNT2 extended keyboard"
arch=(any)
@@ -10,18 +10,19 @@ depends=(
'python-lxml'
)
source=(
- 'abnt2_ext'
+ 'abnt2ext'
'patch_evdev.py'
'abnt2-patch-evdev.hook'
)
-sha256sums=('c5f1cfe3cabb17c0912409fa9c283a360a7d1ae9407751b484b5c2b7f8f48c01'
+sha256sums=('1cb4058afc71968999b188ddd99813a9faaa0baf38cacd7e81f5e048186dfb67'
'74194d63c9bde72e8cd9a4c05d2711cda99a2208bc0ce43b0d6973aaae5edee3'
'cc2b039de1cf0f6e179a3fdb9c6c9959626e9378343388aadf63e05a3f2fc93a')
+install=abnt2-ext.install
package() {
cd "$srcdir/"
- install -D -m 644 -o root -g root abnt2_ext "$pkgdir/usr/share/X11/xkb/symbols/abnt2_ext"
+ install -D -m 644 -o root -g root abnt2ext "$pkgdir/usr/share/X11/xkb/symbols/abnt2ext"
install -D -m 644 -o root -g root patch_evdev.py "$pkgdir/usr/share/abnt2-ext/patch_evdev.py"
install -D -m 644 -o root -g root abnt2-patch-evdev.hook "$pkgdir/usr/share/libalpm/hooks/abnt2-patch-evdev.hook"
}
diff --git a/abnt2-ext.install b/abnt2-ext.install
new file mode 100644
index 000000000000..3186cacf2c60
--- /dev/null
+++ b/abnt2-ext.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "To activate the keymap, run (as root):"
+ echo ""
+ echo " localectl set-x11-keymap --no-convert abnt2ext"
+ echo ""
+}
+
+post_upgrade() {
+ post_install "$@"
+}
diff --git a/abnt2_ext b/abnt2_ext
deleted file mode 100644
index 414f65f97724..000000000000
--- a/abnt2_ext
+++ /dev/null
@@ -1,59 +0,0 @@
-default partial alphanumeric_keys
-
-xkb_symbols "abnt2" {
- include "latin"
- name[group1]="Portuguese (ABNT2 Extended)";
-
- key <AE01> { [ 1, exclam, onesuperior, exclamdown ] };
- key <AE02> { [ 2, at, twosuperior, onehalf ] };
- key <AE03> { [ 3, numbersign, threesuperior, threequarters ] };
- key <AE04> { [ 4, dollar, dead_currency, onequarter ] };
- key <AE05> { [ 5, percent, permille, NoSymbol ] };
- key <AE06> { [ 6, dead_diaeresis, notsign, dead_doubleacute ] };
- key <AE07> { [ 7, ampersand, enfilledcircbullet, plusminus ] };
- key <AE08> { [ 8, asterisk, multiply, division ] };
- key <AE09> { [ 9, parenleft, leftsinglequotemark, leftdoublequotemark ] };
- key <AE10> { [ 0, parenright, rightsinglequotemark, rightdoublequotemark ] };
- key <AE11> { [ minus, underscore, endash, emdash ] };
- key <AE12> { [ equal, plus, section, notequal ] };
- key <AD01> { [ q, Q, slash, backslash ] };
- key <AD02> { [ w, W, question, questiondown ] };
- key <AD03> { [ e, E, EuroSign, U212F ] };
- key <AD04> { [ r, R, NoSymbol, registered ] };
- key <AD05> { [ t, T, thorn, THORN ] };
- key <AD06> { [ y, Y, NoSymbol, NoSymbol ] };
- key <AD07> { [ u, U, udiaeresis, Udiaeresis ] };
- key <AD08> { [ i, I, infinity, NoSymbol ] };
- key <AD09> { [ o, O, oe, OE ] };
- key <AD10> { [ p, P, oslash, Oslash ] };
- key <AD11> { [ dead_acute, dead_grave, dead_breve, dead_macron ] };
- key <AD12> { [ bracketleft, braceleft, ordfeminine, guillemotleft ] };
- key <AC01> { [ a, A, ae, AE ] };
- key <AC02> { [ s, S, ssharp, musicalsharp ] };
- key <AC03> { [ d, D, eth, ETH ] };
- key <AC04> { [ f, F, function, NoSymbol ] };
- key <AC05> { [ g, G, dead_greek, NoSymbol ] };
- key <AC06> { [ h, H, U02BE, U02BF ] };
- key <AC07> { [ j, J, NoSymbol, NoSymbol ] };
- key <AC08> { [ k, K, kra, checkmark ] };
- key <AC09> { [ l, L, lstroke, Lstroke ] };
- key <AC10> { [ ccedilla, Ccedilla, dead_cedilla, dead_ogonek ] };
- key <AC11> { [ dead_tilde, dead_circumflex, dead_caron, dead_belowmacron ] };
- key <TLDE> { [ apostrophe, quotedbl, minutes, seconds ] };
- key <BKSL> { [ bracketright, braceright, masculine, guillemotright ] };
- key <AB01> { [ z, Z, leftarrow, U27F7 ] };
- key <AB02> { [ x, X, uparrow, U2715 ] };
- key <AB03> { [ c, C, downarrow, copyright ] };
- key <AB04> { [ v, V, rightarrow, NoSymbol ] };
- key <AB05> { [ b, B, U20BF, musicalflat ] };
- key <AB06> { [ n, N, NoSymbol, U266E ] };
- key <AB07> { [ m, M, mu, trademark ] };
- key <AB08> { [ comma, less, ellipsis, lessthanequal ] };
- key <AB09> { [ period, greater, NoSymbol, greaterthanequal ] };
- key <AB10> { [ semicolon, colon, dead_belowdot, dead_abovedot ] };
- key <LSGT> { [ backslash, bar, dead_stroke, dead_abovering ] };
- key <AB11> { [ slash, question, degree, questiondown ] };
-
- include "kpdl(comma)"
- include "level3(ralt_switch)"
-};
diff --git a/abnt2ext b/abnt2ext
new file mode 100644
index 000000000000..3e9eb9654b11
--- /dev/null
+++ b/abnt2ext
@@ -0,0 +1,59 @@
+default partial alphanumeric_keys
+
+xkb_symbols "abnt2" {
+ include "latin"
+ name[group1] ="Portuguese (ABNT2 Extended)";
+
+ key <AE01> { [ 1, exclam, onesuperior, exclamdown ] };
+ key <AE02> { [ 2, at, twosuperior, onehalf ] };
+ key <AE03> { [ 3, numbersign, threesuperior, threequarters ] };
+ key <AE04> { [ 4, dollar, dead_currency, onequarter ] };
+ key <AE05> { [ 5, percent, permille, NoSymbol ] };
+ key <AE06> { [ 6, dead_diaeresis, notsign, dead_doubleacute ] };
+ key <AE07> { [ 7, ampersand, enfilledcircbullet, plusminus ] };
+ key <AE08> { [ 8, asterisk, multiply, division ] };
+ key <AE09> { [ 9, parenleft, leftsinglequotemark, leftdoublequotemark ] };
+ key <AE10> { [ 0, parenright, rightsinglequotemark, rightdoublequotemark ] };
+ key <AE11> { [ minus, underscore, endash, emdash ] };
+ key <AE12> { [ equal, plus, section, notequal ] };
+ key <AD01> { [ q, Q, slash, backslash ] };
+ key <AD02> { [ w, W, question, questiondown ] };
+ key <AD03> { [ e, E, EuroSign, U212F ] };
+ key <AD04> { [ r, R, NoSymbol, registered ] };
+ key <AD05> { [ t, T, thorn, THORN ] };
+ key <AD06> { [ y, Y, NoSymbol, NoSymbol ] };
+ key <AD07> { [ u, U, udiaeresis, Udiaeresis ] };
+ key <AD08> { [ i, I, infinity, NoSymbol ] };
+ key <AD09> { [ o, O, oe, OE ] };
+ key <AD10> { [ p, P, oslash, Oslash ] };
+ key <AD11> { [ dead_acute, dead_grave, dead_breve, dead_macron ] };
+ key <AD12> { [ bracketleft, braceleft, ordfeminine, guillemotleft ] };
+ key <AC01> { [ a, A, ae, AE ] };
+ key <AC02> { [ s, S, ssharp, musicalsharp ] };
+ key <AC03> { [ d, D, eth, ETH ] };
+ key <AC04> { [ f, F, function, NoSymbol ] };
+ key <AC05> { [ g, G, dead_greek, NoSymbol ] };
+ key <AC06> { [ h, H, U02BE, U02BF ] };
+ key <AC07> { [ j, J, NoSymbol, NoSymbol ] };
+ key <AC08> { [ k, K, kra, checkmark ] };
+ key <AC09> { [ l, L, lstroke, Lstroke ] };
+ key <AC10> { [ ccedilla, Ccedilla, dead_cedilla, dead_ogonek ] };
+ key <AC11> { [ dead_tilde, dead_circumflex, dead_caron, dead_belowmacron ] };
+ key <TLDE> { [ apostrophe, quotedbl, minutes, seconds ] };
+ key <BKSL> { [ bracketright, braceright, masculine, guillemotright ] };
+ key <AB01> { [ z, Z, leftarrow, U27F7 ] };
+ key <AB02> { [ x, X, uparrow, U2715 ] };
+ key <AB03> { [ c, C, downarrow, copyright ] };
+ key <AB04> { [ v, V, rightarrow, NoSymbol ] };
+ key <AB05> { [ b, B, U20BF, musicalflat ] };
+ key <AB06> { [ n, N, NoSymbol, U266E ] };
+ key <AB07> { [ m, M, mu, trademark ] };
+ key <AB08> { [ comma, less, ellipsis, lessthanequal ] };
+ key <AB09> { [ period, greater, NoSymbol, greaterthanequal ] };
+ key <AB10> { [ semicolon, colon, dead_belowdot, dead_abovedot ] };
+ key <LSGT> { [ backslash, bar, dead_stroke, dead_abovering ] };
+ key <AB11> { [ slash, question, degree, questiondown ] };
+
+ include "kpdl(comma)"
+ include "level3(ralt_switch)"
+};