summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
-rw-r--r--abntex.install17
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4521444eb900
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = abntex
+ pkgdesc = abntex is a class LaTeX for writing documents in ABNT standard.
+ pkgver = 0.9_beta2
+ pkgrel = 2
+ url = http://abntex.sourceforge.net/
+ install = abntex.install
+ arch = i686
+ arch = x86_64
+ license = LPPL
+ depends = texlive-core
+ source = http://downloads.sourceforge.net/sourceforge/abntex/abntex-0.9-beta2.tar.gz
+ md5sums = 4c5bc2d5388ddf03df754072116ab1f8
+
+pkgname = abntex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d56137c5a638
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tiago Camargo <tcamargo@gmail.com>
+# Contributor: Robson Roberto Souza Peixoto <robsonpeixoto@gmail.com>
+pkgname=abntex
+pkgver=0.9_beta2
+_pkgver=${pkgver/_/-}
+pkgrel=2
+pkgdesc='abntex is a class LaTeX for writing documents in ABNT standard.'
+arch=('i686' 'x86_64')
+url="http://abntex.sourceforge.net/"
+license=('LPPL')
+depends=('texlive-core')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${_pkgver}.tar.gz")
+md5sums=('4c5bc2d5388ddf03df754072116ab1f8')
+
+package() {
+ cd "${srcdir}/${pkgname}-${_pkgver:0:3}"
+
+ # Lyx layout
+ install -D -m 644 lyx/layouts/abnt.layout \
+ "${pkgdir}/usr/share/lyx/layouts/abnt.layout"
+
+ install -dm755 "${pkgdir}/usr/share/texmf-dist/"
+
+ for subdir in bibtex makeindex tex; do
+ cp -r "texmf/${subdir}" "${pkgdir}/usr/share/texmf-dist/"
+ done
+
+ cd "${pkgdir}/usr/share/texmf-dist"
+ find . -type d -exec chmod 755 {} \;
+ find . -type f -exec chmod 644 {} \;
+}
diff --git a/abntex.install b/abntex.install
new file mode 100644
index 000000000000..aab5fac4d250
--- /dev/null
+++ b/abntex.install
@@ -0,0 +1,17 @@
+# arg 1: the new package version
+post_install() {
+ texconfig-sys rehash
+ updmap-sys --quiet --nohash
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+post_remove() {
+ post_install
+}
+