summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO21
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--abraca.install13
4 files changed, 88 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8a0f92201f8e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,21 @@
+pkgbase = abraca
+ pkgdesc = A GTK3 client for the XMMS2 music player, with a focus on collections
+ pkgver = 0.7.1
+ pkgrel = 5
+ url = http://abraca.github.com/Abraca/
+ install = abraca.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = scons
+ makedepends = vala>=0.18.0
+ makedepends = python2
+ makedepends = gettext
+ depends = gtk3
+ depends = xmms2
+ depends = libgee
+ depends = hicolor-icon-theme
+ source = https://github.com/abraca/abraca/tarball/master
+
+pkgname = abraca
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8c36a02da8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = abraca
+ pkgdesc = A GTK3 client for the XMMS2 music player, with a focus on collections
+ pkgver = 0.7.1
+ pkgrel = 5
+ url = http://abraca.github.com/Abraca/
+ install = abraca.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = scons
+ makedepends = vala>=0.18.0
+ makedepends = python2
+ makedepends = gettext
+ depends = gtk3
+ depends = xmms2
+ depends = libgee
+ depends = hicolor-icon-theme
+ source = https://github.com/abraca/abraca/tarball/master
+ sha512sums = 793b505e8657ffd18bff6b9f5ae22353417833cb3b79a95570be1aea7caf07e8cd54042b5edc6c2a0d04bc72063372e2e3e3edda3bdf44eb28a92a426f4a5726
+
+pkgname = abraca
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0fb837082b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#! /bin/bash
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Johan Slikkie <johan@slikkie.nl>
+# Maintainer: jorge_barroso <jorge.barroso.11@gmail.com>
+
+pkgname=abraca
+pkgver=0.7.1
+_fullpkgver=0.7.1-107-g1dbef52
+pkgrel=5
+pkgdesc="A GTK3 client for the XMMS2 music player, with a focus on collections"
+arch=('x86_64' 'i686')
+url="http://abraca.github.com/Abraca/"
+license=('GPL')
+depends=('gtk3' 'xmms2' 'libgee' 'hicolor-icon-theme')
+makedepends=('scons' 'vala>=0.18.0' 'python2' 'gettext')
+install=abraca.install
+sha512sums=('793b505e8657ffd18bff6b9f5ae22353417833cb3b79a95570be1aea7caf07e8cd54042b5edc6c2a0d04bc72063372e2e3e3edda3bdf44eb28a92a426f4a5726')
+source=(https://github.com/$pkgname/$pkgname/tarball/master)
+
+build() {
+
+ cd "$srcdir"/*
+
+ ./waf configure --prefix=/usr
+ ./waf build
+}
+
+package() {
+ ./waf install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abraca.install b/abraca.install
new file mode 100644
index 000000000000..a252f4e6be69
--- /dev/null
+++ b/abraca.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ echo""
+ echo "---If integrity check fails, flag the package as outdated, because version releases of this package are a bit strange and it's not easy to know when there's a new version"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}