summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--abricotine.desktop11
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58e1e70dc40b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = abricotine-git
+ pkgdesc = A markdown editor with inline preview
+ pkgver = latest
+ pkgrel = 1
+ url = http://abricotine.brrd.fr
+ arch = x86_64
+ license = GPL3
+ makedepends = npm
+ depends = gconf
+ depends = libxss
+ conflicts = abricotine
+ source = abricotine::git+https://github.com/brrd/abricotine
+ source = abricotine.desktop
+ sha256sums = SKIP
+ sha256sums = 164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c
+
+pkgname = abricotine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50514daf2982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Frank Seifferth <frankseifferth@posteo.net>
+
+pkgname=abricotine-git
+_pkgname=abricotine
+conflicts=("abricotine")
+pkgver=latest
+pkgrel=1
+pkgdesc="A markdown editor with inline preview"
+arch=('x86_64')
+url="http://abricotine.brrd.fr"
+license=('GPL3')
+depends=('gconf' 'libxss')
+makedepends=('npm')
+source=("abricotine::git+https://github.com/brrd/abricotine"
+ "abricotine.desktop")
+sha256sums=('SKIP'
+ '164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c')
+
+pkgver() {
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/abricotine"
+
+ npm install --cache ../cache --devdir="$srcdir/devdir"
+ npm run packager
+}
+
+package() {
+ cd "$srcdir/abricotine"
+
+ install -d "$pkgdir/opt/abricotine"
+ cp -r dist/*/* "$pkgdir/opt/abricotine"
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/abricotine/Abricotine" "$pkgdir/usr/bin/abricotine"
+
+ install -Dm644 "../abricotine.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "icons/abricotine@2x.png" "$pkgdir/usr/share/pixmaps/abricotine.png"
+}
diff --git a/abricotine.desktop b/abricotine.desktop
new file mode 100644
index 000000000000..29aae338cf05
--- /dev/null
+++ b/abricotine.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Abricotine
+GenericName=Abricotine
+Comment=A markdown editor with inline preview
+Exec=abricotine %F
+Icon=abricotine
+Terminal=false
+Type=Application
+Categories=Office;TextEditor;
+MimeType=text/markdown;
+Keywords=Text;Editor;Markdown;