summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD131
-rw-r--r--license.txt83
3 files changed, 133 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5342aa486617..9d808a4750bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,29 @@
pkgbase = ace
pkgdesc = Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems.
- pkgver = 6.4.6
+ pkgver = 7.1.4
pkgrel = 1
- url = http://www.dre.vanderbilt.edu/~schmidt/ACE.html
- arch = i686
+ url = https://www.dre.vanderbilt.edu/~schmidt/ACE.html
arch = x86_64
- license = custom
- conflicts = libace
- options = !libtool
- source = http://download.dre.vanderbilt.edu/previous_versions/ACE-6.4.6.tar.gz
- source = license.txt
- sha256sums = 36baa2ae1768060d23e7c78db1cab7e804ee53a5825d093c918e7086398a25e1
- sha256sums = 4aef434f0bc8c91488f92b25863e5dcbff857598389276718c59903cd8c8c954
+ license = DOC
+ makedepends = perl
+ depends = gcc-libs
+ depends = glibc
+ optdepends = perl: MPC support
+ provides = libACE.so
+ provides = libACEXML.so
+ provides = libACEXML_Parser.so
+ provides = libACEXML_XML_Svc_Conf_Parser.so
+ provides = libACE_Compression.so
+ provides = libACE_ETCL.so
+ provides = libACE_ETCL_Parser.so
+ provides = libACE_HTBP.so
+ provides = libACE_INet.so
+ provides = libACE_Monitor_Control.so
+ provides = libACE_RLECompression.so
+ provides = libACE_RMCast.so
+ provides = libACE_TMCast.so
+ provides = libKokyu.so
+ source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-7_1_4/ACE-src-7.1.4.tar.gz
+ sha256sums = 97b83924ef161e6d8869b95d73b2553e19f79a2bb326dcb0092cd376b971dedf
pkgname = ace
-
diff --git a/PKGBUILD b/PKGBUILD
index 2ce7fe8f3b8c..950119297ee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
-# Maintainer : alrii <alrii@gmail.com>
+# Maintainer: vetu104 <janne.p.w.vetelainen@gmail.com>
+# Contributor: Viste <viste02@gmail.com>
+# Contributor: alrii <alrii@gmail.com>
# Contributor: jjpk <julienjpk@email.com>
# Contributor: Benjamin Chrétien <chretien at lirmm dot fr>
# Contributor: DaNiMoTh <jjdanimoth@gmail.com>
@@ -7,31 +9,118 @@
# Contributor: Alex Belanger <i.caught.air@gmail.com>
pkgname=ace
-pkgver=6.4.6
+_pkgver=7_1_4
+pkgver=7.1.4
pkgrel=1
pkgdesc="Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems."
-url="http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
-license=('custom')
-arch=('i686' 'x86_64')
-depends=()
-options=(!libtool)
-conflicts=('libace')
-source=("http://download.dre.vanderbilt.edu/previous_versions/ACE-${pkgver}.tar.gz"
- "license.txt")
-sha256sums=('36baa2ae1768060d23e7c78db1cab7e804ee53a5825d093c918e7086398a25e1'
- '4aef434f0bc8c91488f92b25863e5dcbff857598389276718c59903cd8c8c954')
+arch=('x86_64')
+url="https://www.dre.vanderbilt.edu/~schmidt/ACE.html"
+license=('DOC')
+depends=('gcc-libs' 'glibc')
+makedepends=('perl')
+optdepends=(
+ 'perl: MPC support'
+)
+provides=('libACE.so' 'libACEXML.so' 'libACEXML_Parser.so'
+ 'libACEXML_XML_Svc_Conf_Parser.so' 'libACE_Compression.so'
+ 'libACE_ETCL.so' 'libACE_ETCL_Parser.so' 'libACE_HTBP.so' 'libACE_INet.so'
+ 'libACE_Monitor_Control.so' 'libACE_RLECompression.so' 'libACE_RMCast.so'
+ 'libACE_TMCast.so' 'libKokyu.so'
+)
+
+source=("https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-$_pkgver/ACE-src-$pkgver.tar.gz")
+sha256sums=('97b83924ef161e6d8869b95d73b2553e19f79a2bb326dcb0092cd376b971dedf')
+
+prepare() {
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+
+ # Disable expandtab if modifying these here-strings
+ # Indentation in resulted file is wrong if indented with spaces
+
+ # Built a select subset of components in the ACE release
+ # Inspired by Debian
+ cat <<-EOF > "$ACE_ROOT/ACE.mwc"
+ workspace {
+ exclude {
+ apps/gperf/tests
+ apps/Gateway
+ apps/JAWS
+ apps/JAWS2
+ apps/JAWS3
+ apps/drwho
+ apps/mkcsregdb
+ apps/soreduce
+
+ ACEXML/tests
+ Kokyu/tests
+ ACEXML/examples
+ netsvcs/clients
+ protocols/examples
+
+ ASNMP
+ examples
+ performance-tests
+ websvcs
+ }
+ }
+ EOF
+}
build() {
- export ACE_ROOT=$srcdir/ACE_wrappers
- cd $ACE_ROOT
- echo '#include "ace/config-linux.h"' > ace/config.h
- echo 'INSTALL_PREFIX = /usr
- include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU' > include/makeinclude/platform_macros.GNU
- cd ace
- make
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+
+ cat <<-EOF > "$ACE_ROOT/ace/config.h"
+ #include "ace/config-linux.h"
+ EOF
+
+ cat <<-EOF > "$ACE_ROOT/include/makeinclude/platform_macros.GNU"
+ INSTALL_PREFIX = /usr
+ include \$(ACE_ROOT)/include/makeinclude/platform_linux.GNU
+ EOF
+
+ #cat <<-EOF > "$ACE_ROOT/bin/MakeProjectCreator/config/default.features"
+ #EOF
+
+ export LD_LIBRARY_PATH="$ACE_ROOT/lib:$LD_LIBRARY_PATH"
+ "$ACE_ROOT/bin/mwc.pl" -type gnuace ACE.mwc
+ make
+}
+
+check() {
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ export LD_LIBRARY_PATH="$ACE_ROOT/lib:$LD_LIBRARY_PATH"
+ cd "$ACE_ROOT"
+
+ # Tests that are failing on my system
+ # (Clean chroot, kernel defaults sysctl, limits)
+ sed -i '/Bug_2610_Regression_Test/d' "$ACE_ROOT/tests/run_test.lst"
+ sed -i '/Bug_2740_Regression_Test/d' "$ACE_ROOT/tests/run_test.lst"
+ sed -i '/Bug_3943_Regression_Test/d' "$ACE_ROOT/tests/run_test.lst"
+ sed -i '/MT_Reference_Counted_Event_Handler_Test/d' "$ACE_ROOT/tests/run_test.lst"
+ sed -i '/INET_Addr_Test_IPV6/d' "$ACE_ROOT/tests/run_test.lst"
+ sed -i '/Multicast_Test_IPV6/d' "$ACE_ROOT/tests/run_test.lst"
+
+ "$ACE_ROOT/bin/auto_run_tests.pl" -Config FIXED_BUGS_ONLY 2>&1 | tee tests.log
+
+ local status=0
+
+ echo "--- Failed tests:"
+ if grep "auto_run_tests_finished" tests.log |
+ grep -v "Result:0"; then
+ status=1
+ else
+ echo "None."
+ fi
+ echo "---"
+
+ return "$status"
}
package() {
- cd $srcdir/ACE_wrappers/ace
- make DESTDIR="$pkgdir/" install
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/license.txt b/license.txt
deleted file mode 100644
index f4d029f1ef6d..000000000000
--- a/license.txt
+++ /dev/null
@@ -1,83 +0,0 @@
-Copyright and Licensing Information for ACE(TM), TAO(TM), CIAO(TM), and
-CoSMIC(TM)
-ACE(TM), TAO(TM), CIAO(TM), and CoSMIC(TM) (henceforth referred to as
-"DOC software") are copyrighted by Douglas C. Schmidt and his research
-group at Washington University, University of California, Irvine, and
-Vanderbilt University, Copyright (c) 1993-2006, all rights reserved.
-Since DOC software is open-source, freely available software, you are
-free to use, modify, copy, and distribute--perpetually and
-irrevocably--the DOC software source code and object code produced from
-the source, as well as copy and distribute modified versions of this
-software. You must, however, include this copyright statement along with
-any code built using DOC software that you release. No copyright
-statement needs to be provided if you just ship binary executables of
-your software products.
-
-You can use DOC software in commercial and/or binary software releases
-and are under no obligation to redistribute any of your source code that
-is built using DOC software. Note, however, that you may not do anything
-to the DOC software code, such as copyrighting it yourself or claiming
-authorship of the DOC software code, that will prevent DOC software from
-being distributed freely using an open-source development model. You
-needn't inform anyone that you're using DOC software in your software,
-though we encourage you to let us know so we can promote your project in
-the DOC software success stories.
-
-The ACE, TAO, CIAO, and CoSMIC web sites are maintained by the DOC Group
-at the Institute for Software Integrated Systems (ISIS) and the Center
-for Distributed Object Computing of Washington University, St. Louis for
-the development of open-source software as part of the open-source
-software community. By submitting comments, suggestions, code, code
-snippets, techniques (including that of usage) and algorithms
-(collectively ``Submissions''), submitters acknowledge that they have
-the right to do so, that any such Submissions are given freely and
-unreservedly, and that they waive any claims to copyright or ownership.
-In addition, submitters acknowledge that any such Submission might
-become part of the copyright maintained on the overall body of code that
-comprises the DOC software. By making a Submission, submitter agree to
-these terms. Moreover, submitters acknowledge that the incorporation or
-modification of such Submissions is entirely at the discretion of the
-moderators of the open-source DOC software projects or their designees.
-
-Submissions are provided by the submitter ``as is'' with no warranties
-whatsoever, including any warranty of merchantability, noninfringement
-of third party intellectual property, or fitness for any particular
-purpose. In no event shall the submitter be liable for any direct,
-indirect, special, exemplary, punitive, or consequential damages,
-including without limitation, lost profits, even if advised of the
-possibility of such damages. Likewise, DOC software is provided as is
-with no warranties of any kind, including the warranties of design,
-merchantability, and fitness for a particular purpose, noninfringement,
-or arising from a course of dealing, usage or trade practice. Washington
-University, UC Irvine, Vanderbilt University, their employees, and
-students shall have no liability with respect to the infringement of
-copyrights, trade secrets or any patents by DOC software or any part
-thereof. Moreover, in no event will Washington University, UC Irvine, or
-Vanderbilt University, their employees, or students be liable for any
-lost revenue or profits or other special, indirect and consequential
-damages.
-
-DOC software is provided with no support and without any obligation on
-the part of Washington University, UC Irvine, Vanderbilt University,
-their employees, or students to assist in its use, correction,
-modification, or enhancement. A number of companies around the world
-provide commercial support for DOC software, however.
-
-DOC software is Y2K-compliant, as long as the underlying OS platform is
-Y2K-compliant. Likewise, DOC software is compliant with the new US
-daylight savings rule passed by Congress as "The Energy Policy Act of
-2005," which established new daylight savings times (DST) rules for the
-United States that expand DST as of March 2007. Since DOC software
-obtains time/date and calendaring information from operating systems
-users will not be affected by the new DST rules as long as they upgrade
-their operating systems accordingly.
-
-The names ACE(TM), TAO(TM), CIAO(TM), CoSMIC(TM), Washington University,
-UC Irvine, and Vanderbilt University, may not be used to endorse or
-promote products or services derived from this source without express
-written permission from Washington University, UC Irvine, or Vanderbilt
-University. Further, products or services derived from this source may
-not be called ACE(TM), TAO(TM), CIAO(TM), or CoSMIC(TM) nor may the name
-Washington University, UC Irvine, or Vanderbilt University appear in
-their names, without express written permission from Washington
-University, UC Irvine, and Vanderbilt University.